Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need your help,

when I launch Nautilus it crashes in 2 secons + desktop icons aren't displayed. I tried to uninstall python-nautilus but it doesn't work for me + don't have any zero byte file. Using terminal: Unauthorized access to memory SIGSEGV

Thank you :)

share|improve this question

1 Answer 1

After 2 days trying fix it, I found the problem. Nautilus couldn't display .j2k file on desktop. When I deleted this .j2k file (which btw was not zero byte!) nautilus started working fine.
I wonder that .j2k is not supported!!!

share|improve this answer
1  
Can you explain more how you fix it? I have similar problem, but cant find any .j2k file. Nautilus works fine if it's not selected the "show desktop icons" option, but if selected, nautilus immediately crashes. This is the error message running from terminal: The program 'nautilus' received an X Window System error. This probably reflects a bug in the program. The error was 'BadMatch (invalid parameter attributes)'. (Details: serial 639 error_code 8 request_code 139 minor_code 4) (Note to programmers: normally, X errors are reported asynchronously; that is, you will receive the error a while a –  Roberto Apr 24 at 23:57
    
I'm just an ordinary PC user so I have only a few tips. Try to check if you haven't created an unusual file on desktop (I fixed it by chance - I deleted the .j2k file), try to launch nautilus in terminal with sudo rights (running sudo nautilus it didn't crash immediately like in normal mode, crashed only when opened the directory with unsupported file so it worked as a diagnosis for me :D). –  user257261 Apr 26 at 21:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.