Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running 11.04. I have Skype running but it does not show up in the notification tray. It was working until I added Skype to auto-start when I log in. Does anyone know how to make it reappear?

share|improve this question
    
One other option you might consider is adding Skype to the messaging menu: omgubuntu.co.uk/2011/04/… –  mvario May 17 '11 at 22:40

6 Answers 6

You can get skype tray in 11.10 and 12.04 installing package sni-qt:i386

sudo apt-get install sni-qt:i386

OR

You can whitelist systray as well

How do I access and enable more icons to be in the system tray?

OR

If you like how empathy and messaging tray work you can install a third party skype-wrapper package from ppa which enables skype to indicator-message

enter image description here

You can install by

  • sudo add-apt-repository ppa:skype-wrapper/ppa
  • sudo apt-get update && sudo apt-get install skype-wrapper

SOURCE

share|improve this answer
    
cool, whitelisting the systray to 'all' worked! thanks –  herpson Apr 27 '12 at 6:51
    
sni-qt:i386 installation on 64bit machine solves the skype tray problem in ubuntu 12.04 too (gnome classic with no effects) –  Mariuz May 22 '12 at 13:49
    
skype-wrapper is indeed a very nice thing to have. A shame that it's still a bit buggy. –  con-f-use Jul 5 '12 at 20:30

Install dconf-tools Install dconf-tools / sudo apt-get install dconf-tools.

Then run the conf editor by typing:

dconf-editor

at the command line.

There under:

desktop
   ->unity
      ->panel

enter image description here

change the line that says:

['JavaEmbeddedFrame', 'Mumble', 'Wine', 'hp-systray', 'scp-dbus-service']` 

into this here:

['JavaEmbeddedFrame', 'Mumble', 'Wine', 'hp-systray', 'scp-dbus-service', 'Skype']

You can change it to ['all'] which allows all tray applications to show there icons in the indicator bar (Ah-Duh!). As usual changes will take effect only after reboot or restarting unity by Alt+F2ing

unity --replace &
share|improve this answer

Make sure you are not experiencing this bug (Launchpad.net)

Sometimes, the Skype indicator is only one green pixel. It's easy to overlook and assume there is no indicator at all.

If this is the case, just quit and restart Skype and it will come back normally. I have this quite often.

share|improve this answer
    
Thanks JE2Tom. I am experience the green pixel in the notification area. But i fail to get a proper icon even after restarting skype. It come up again just as a pixel. –  user18708 May 27 '11 at 6:16

I have figured out the cause and the fix, at least in my case.

The problem was that Skype was loading before the systray application. The solution was to delay Skype on start up. Someone else may have a more programmer worthy fix, but my solution was to change my KDE startup options to "start with a blank session" instead of remembering the last session. I then created a file in ~/.kde/Autostart with the name skype.sh, here's the text I put in mine:

#!/bin/dash

sleep 15
/usr/bin/skype
exit

Afterward I did a chmod +x ~/.kde/Autostart/skype.sh

It's working great.

share|improve this answer

In skypes' options try selection Start skype minimized on startup .That worked for me.It might wok for you

share|improve this answer
    
Nope, didnt work for me. whitelisting did though –  herpson Apr 27 '12 at 6:51
    
Im srry it didnt. –  Ashu Apr 27 '12 at 7:09

For me in 14.04;

  1. Open "dconf editor"

  2. Search "systray" (couldn't find in other answers on mine)

  3. On "show-icon-on-systray" click off the tick then back on again, then click "restore default" button.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.