Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

[Preface: I have seen similar questions, but that did not help me and so this new question. To explain in more detail, I followed the steps in How do I resolve unmet dependencies?, without rectifying the problem]

I am trying to install ccmake.

However, I get the following error:

sudo apt-get install cmake-curses-gui
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cmake-curses-gui : Depends: cmake (= 2.8.7-0ubuntu4)
E: Unable to correct problems, you have held broken packages.

I tried sudo apt-get -f install, but it did not help.

I am unable to find broken packages either.

share|improve this question

marked as duplicate by Florian Diesch, dobey, Eric Carvalho, i08in, Radu Rădeanu Mar 11 at 19:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Yes, I followed that. –  Manas Paldhe Mar 11 at 14:51
    
It did not sort out my problem and hence I posted another question. :) –  Manas Paldhe Mar 11 at 14:52
    
did u try sudo dpkg --configure -a –  Stormvirux Mar 11 at 14:57
    
Yes. Still the same error occurs. $ sudo dpkg --configure -a $ sudo apt-get install cmake-curses-gui ** something** Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: cmake-curses-gui : Depends: cmake (= 2.8.7-0ubuntu4) E: Unable to correct problems, you have held broken packages. $ –  Manas Paldhe Mar 11 at 15:08
    
What is the output of sudo apt-get check, apt-cache policy cmake-curses-gui cmake and cat /etc/apt/sources.list{,.d/*.list} –  Braiam Mar 12 at 0:34

1 Answer 1

cmake-curses-gui depends on cmake (= 2.8.7-0ubuntu4) for a precise installation.

If you're unable to install this particular version it means that you installed a different version on your system.

Try first to uninstall cmake:

sudo apt-get remove cmake

And install again cmake-curses-gui:

sudo apt-get install cmake-curses-gui

If it doesn't work check if you're not pulling a different version of cmake from a ppa.

share|improve this answer
    
Same error. How do I confirm that I am not pulling a different version of cmake from a ppa? –  Manas Paldhe Mar 11 at 19:30
    
Do apt-cache policy cmake. –  saiarcot895 Mar 11 at 19:32
    
Installed: 2.8.7-0ubuntu4 Candidate: 2.8.7-0ubuntu4 Version table: *** 2.8.7-0ubuntu4 0 500 us.archive.ubuntu.com/ubuntu precise/main amd64 Packages 100 /var/lib/dpkg/status –  Manas Paldhe Mar 11 at 19:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.