Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed eclipse (ultimate edition 3.5) in Ubuntu 12.04 via the terminal. I also installed the ADT plugin in the eclipse program via install new software. Everything has completed but eclipse is asking for the location of sdk. Where is sdk located on my computer?

share|improve this question
    
Please run cd $HOME && ls | grep android and see if that helps you find the location of the SDK. –  Chris Mar 11 at 6:26

2 Answers 2

You need to download Android sdk manually from Android official website.

Download the file and extract it wherever you want.

Now open your eclipse and go to WindowPreferencesAndroidSDK Location and click on browse button to select the exacted sdk folder.

You can also use ADT Bundle which is preconfigured with all components in portable form

Please see here for more information.

share|improve this answer
    
i just did like u said but when i click on it, it will say open with and ask me to select the application to open eclipse, i cant open the eclipse –  Mukund Mar 11 at 6:55
    
what is the extension of file you have downloaded. However if something went wrong this is the exact link of the file you need to configure your existing updated eclipse environment. dl.google.com/android/android-sdk_r22.6-linux.tgz –  g_p Mar 11 at 7:00
    
it says executable, it is working in 10.04 ubuntu but not in this version why? –  Mukund Mar 11 at 7:02
    
Try to open it using terminal. first cd <path_to_folder> and then ./<file_name> –  g_p Mar 11 at 7:05
    
i did i went to the folder where i upzipped adt and took terminal and typed eclipse and when i tried to start sdkmanager an error messege shows. i have taken a screen shot of it –  Mukund Mar 11 at 7:18
  • Download latest sdk from here
  • Extract file using below command.

    tar -zxvf DOWNLOAD-FOLDER/android-sdk_r22.6-linux.tgz
    
  • Move this folder where you want to keep your Android SDK.

  • Open Eclipse Window → Preferences → Android → SDK Location & set sdk location to your extracted SDK folder.

  • Next you need to download google API from Android SDK manager.

  • Click on Android SDK manager, select components you want to install & click on Install Packages.

Or best option is download ADT Bundle which contains Eclipse, ADT & Android SDK inbuilt.

EDIT :


Might be adb don't have execute permissions. Try below command to correct permissions.

chmod -R +x /media/New\ Volume/softwares/ADT\ Ubuntu/android-sdk-linux/platform-tools/*

share|improve this answer
    
i did as u told and installed api, but this error is shown Unable to run 'adb': Cannot run program "/media/New Volume/softwares/ADT Ubuntu/android-sdk-linux/platform-tools/adb": java.io.IOException: error=13, Permission denied. Starting ADB server failed (code -1). –  Mukund Mar 11 at 7:45
    
Might be adb don't have execute permissions. Try below command to correct permissions. chmod -R +x /media/New\ Volume/softwares/ADT\ Ubuntu/android-sdk-linux/platform-tools/* –  Vaibhav Panmand Mar 11 at 8:07
    
i installed ubuntu as a dual boot in my lap, windows was there with an adminstrator account is this the problem? –  Mukund Mar 11 at 10:46
    
dual boot is not a issue with your eclipse setup. Have you tried after changing permissions? can you send the output of mount | grep "New Volume" –  Vaibhav Panmand Mar 11 at 11:19
    
mukund@mukund-ThinkPad-Edge-E431:/media$ mount | grep "New Volume" /dev/sda7 on /media/New Volume type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096) –  Mukund Mar 11 at 11:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.