Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have an AMD Raedon 6770 graphics card in my computer, and for some reason I'm unable to get Ubuntu 13.10 to read it. I had another copy of 13.10 on my desktop, but when I tried to install the .run file for the card from the terminal, it corrupted something within my operating system and I could no longer get Ubuntu to boot. I'm fairly new to this operating system, but am beginning to grasp the concept pretty fast. Is there anyway to add a library of screen resolutions? I really need something with a 16:9 ratio for my Emerson TV screen which I'm using as my monitor, and currently only 4:3 is available (linked tv to computer through a monitor cable).

I've also tried to run a few xrandr commands without any success. Any suggestions would be greatly appreciated!

share|improve this question

marked as duplicate by BuZZ-dEE, Eric Carvalho, Ask, Avinash Raj, Alvar Mar 13 at 20:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers 3

If I understand correctly, you don't have a black screen, but rather are having trouble setting up the correct resolutions? If that's the case, then you should be able to follow this guide.

share|improve this answer
    
I tried this again and actually got to the install screen this time. It installed but said there were errors, so I rebooted it and not I'm unable to get Ubuntu to display again. Says I have a resolution mismatch. And of course theres no way to get into it and change it back (that I know of) unless I can get to the home screen. I unplugged my monitor cable and started using HDMI, and now I can see the start up screen, but once I type in my password the screen goes black once again... –  Jack Sniper Mar 11 at 6:21
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Stormvirux Mar 11 at 6:31

Can you try this workaround to see if it helps?

$ sudo gedit /etc/defaults/grub &

In this file, find the line starting with GRUB_GFXMODE and set to to your screen resolution. For example, if your screen resolution is 1366x768, then,

GRUB_GFXMODE=1366x768

Save the file and close Text Editor. Then execute the following command and reboot to see if it works.

$ sudo update-grub2
share|improve this answer
    
Changed the GFXMODE without any luck –  Jack Sniper Mar 11 at 7:14

If you choose to simply install the drivers after running the .run file rather than generating packages, you may have to run sudo aticonfig --initial and reboot.

In case you aren't aware, there is an easy way to install hardware drivers from Software Sources > Additional Drivers.

Try using the option while running the .run installer to create distribution-specific packages instead. That option will create three .debs, which you should install in this order by clicking the files:

  • fglrx_<version>-0ubuntu1_<architecture>.deb
  • fglrx-dev_<version>-0ubuntu1_<architecture>.deb
  • fglrx-amdcccle_<version>-0ubuntu1_<architecture>.deb

Or, with the terminal command: (assuming the .run file and thus resulting .deb files were directly in your home folder):

sudo dpkg -i fglrx*.deb

And reboot. It's a cleaner way to do things and shouldn't require configuration afterwards, except with dual-monitor scenarios and the like. But probably no terminal stuff.

If you use Kubuntu, you will also have to enable OpenGL detection in System Settings > Desktop Effects.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.