Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For a completely unrelated problem, I ran update-grub following the instructions in user62644's answer to this post. Ever since, the GUI has been loading by default upon boot, and I have to type Ctrl+Alt+F1 to access the bash shell. I would like the bash shell to load by default upon startup, and just type startx whenever I need the GUI. I'm running Ubuntu 12.04 LTS.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Edit /etc/default/grub and change this:

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet splash"

to this:

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet text"

This assumes you actually need the acpi=noirq that was in the linked answer. I can't tell you that, it depends on your hardware. Anyway, once you've done this, refresh grub:

sudo update-grub

And you should now load directly to text.

share|improve this answer
    
Thank you. I've been wondering about the acpi=noirq part. Originally, the settings were GRUB_CMDLINE_LINUX_DEFAULT="" and changing it did not solve the problem it claimed to solve, aka. system hangs upon shutdown (which I solved by using shutdown -HR). To make things short, I have no clue whether or not I need acpi=noirq... –  biohazard Mar 11 at 4:40
    
@biohazard you probably don't, that is usually suggested to solve some graphics problems. You certainly did not solve your shutdown issues by running shutdown -r though, that just reboots. Anyway, the main thing is adding text, that should cause you to boot into text mode. –  terdon Mar 11 at 4:42
    
Sorry, it shut down properly when using shutdown -HR now (power actually went off). I actually haven't tried shutdown -r. Edited my comment above. –  biohazard Mar 11 at 4:43
    
Thank you. It seems like a link is missing in your post after "More details here:" –  biohazard Mar 11 at 4:48
    
OMG sorry it was shutdown -HP now!!! I'm so confused. –  biohazard Mar 11 at 4:52

Use

sudo update-rc.d lightdm remove

And you will see desired bash logon shell on startup

To restore:

sudo update-rc.d lightdm defaults
share|improve this answer
    
Thank you! I hesitated which answer to pick, but I felt that @terdon's answer also took into account the context of the previous instructions I had followed. I will remember your solution in case I encounter this again in the future. –  biohazard Mar 11 at 4:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.