Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to download android_4.2_r1 source code. And I am using Ubuntu 12.04. I've installed jdk 1.6, Python 2.7, Git..

I downloaded repo use this code

$ curl http://code.google.com/p/git-repo/downloads/detail?name=repo-1.12 ~/bin/repo

(Since the official one is forbidden in China... )

Anyway, I initiated repo successfully.

But when I try to repo sync I meet the error:

brendon@brendon-Lenovo:~/android4.2/.repo$ repo sync
fatal: remote error: access denied or repository not exported: /platform/abi/cpp.git
error: Cannot fetch platform/abi/cpp

Does Anyone know the reason? Thank you!


Does this have anything to do with my PATH:

brendon@brendon-Lenovo:~$ $PATH
bash: /home/brendon/bin:/home/brendon/bin:/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games: 
share|improve this question
    
The http://code.google.com/p/git-repo/downloads/detail?name=repo-1.12 returns an HTML document. Are you sure that's the exact curl command you used? –  Dan Mar 10 at 15:40
    
You are using the wrong URL for the repo-1.12 file. –  dobey Mar 10 at 16:15
    
I also tried this one "php.webtutor.pl/en/wp-content/uploads/2011/09/repo";. But both of them run into this problem. Since the original one is forbidden here, people usually use these two methods. –  Brendon Tsai Mar 11 at 1:06
    
@Dan Sorry, I just checked, the curl I was using is "curl git-repo.googlecode.com/files/repo-1.12 > ~/bin/repo". –  Brendon Tsai Mar 11 at 2:07
    
Thank you, guys. I've solved the problem. –  Brendon Tsai Mar 11 at 9:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.