Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I go into a local coffee shop with public wifi and try to connect. The connection shows up in network manager so I click on it and it says it is connected. Apparently the next thing I should do is open a browser and accept the acceptable use policy. However when I open Firefox it just shows the start page which I'm assuming is local and if I try to go anyplace on the internet says "connecting" and never goes anyplace. How am I supposed to get to the "Acceptable Use" page?

The network manager is set to Automatic for everthing and when I sit down and click connect on the indicator icon, after it says connected, it appears to be ready to go. If I edit things in the connection properties that I know will cause it to fail the browser shows the "server not found" page when I try to access the internet, but if I leave everthing set to automatic and get the connection shown below it just freezes at "connecting".

I have tried firefox and chromium and they both act the same, but could there be something in the way I have my browsers configured that aren't allowing them to re-direct to the "acceptable use" page? Are there other tools that might help diagnose what is going on?

State: connected (global)

- Device: wlan0  [TimHortons-US-Staging] ---------------------------------------
  Type:              802.11 WiFi
  Driver:            iwl3945
  State:             connected
  Default:           yes
  HW Address:        <MAC address removed>

  Capabilities:
    Speed:           54 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *TimHortons-US-Staging: Infra, <MAC address removed>, Freq 2437 MHz, Rate 54 Mb/s, Strength 67

  IPv4 Settings:
    Address:         10.2.242.244
    Prefix:          16 (255.255.0.0)
    Gateway:         10.2.1.1

    DNS:             208.67.222.222
    DNS:             208.67.220.220
share|improve this question
    
Ensure that your IP, gateway, and DNS are set to "dynamic" to allow the wifi router to assign them. –  Digital Chris Mar 10 at 13:34
    
It should work "as it". I do it all the time and never encountered problems, so I'm going with @DigitalChris on this. –  MrVaykadji Mar 10 at 13:45
    
I am also encountering this problem and have not found a solution yet. I can connect from my phone (Android) or Windows, but not Ubuntu. Also, I have everything set to dynamic as @DigitalChris suggested didn't make a difference. –  mason81 Aug 29 at 22:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.