Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had some issues with WiFi with my Lenovo y580, I could connect my home WiFi but it would disonnect me after few minutes and I wasn't able to reconnect I have Ubuntu 12.04 and I believe my network card is "AR8161 Gigabit Ethernet"

Changes I have been doing before it stopped working at all:

191  lspci -vv | grep Atheros
192  sudo apt-get install build-essential linux-headers-generic linux-headers-`uname -r`
193  wget -O- http://linuxwireless.org/download/compat-wireless-2.6/compat-wireless-2012-07-03-pc.tar.bz2 | tar -xj
194  cd compat-wireless-2012-07-03-pc
195  ./scripts/driver-select alx
196  make
197  sudo make install
198  sudo modprobe alx

It would be great if I could revert this change so ubuntu would use the previous standard driver.
Then I could at least connect to some WiFi and maybe this problem was router's issue and not my network driver one

Thanks for any help

share|improve this question
    
The device and driver you show are for ehternet not wifi. Please run lspci -nnk | grep -iA2 net lsusb nm-tool sudo iwlist scan iwconfig rfkill list all lsmod post the output at pastebin.com then post the link here. Thanks –  Wild Man Mar 10 at 11:02
    
@WildMan pastebin.com/5vCeNPAd By reinstalling packages listed in following question: askubuntu.com/questions/217361/… I am now back in state where I aws before -home WiFi works for a few minutes, but then disconnects and not even restarting the router does help then... However I have no connection problems with connecting via mobilephone wifi hotspot, however I have 2GB bandwidth limit on mobile and it is rather limiting –  ViRPo Mar 11 at 20:03

1 Answer 1

Ok, after going 4 hours without being disconnected I can say, that I have solved the issue

The solution is to go to Network -> Edit Connections -> Wireless -> Click on WiFi -> Edit -> IPv6 Settings

There, you have to select Method: Ignore

So it is IPv6 related issue. Somehow.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.