Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Kate under Gnome, in Maverick.

After the last Ubuntu update ran, the "enter" key started acting strangely in Kate. I'm guessing it's trying to auto-indent even though I have auto-indent off.

Settings: settings

But when I'm in a CSS file, and I hit the "enter" key once, the cursor jumps down 2 lines, and indents 3 spaces.

I just use Kate as a text editor (I use it because it has the best syntax highlighting) and I'm at a loss. Any suggestions/ideas are very welcome.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Under Open/Save → Modes & Filetypes you'll find that the Markup/CSS filetype has an indentation profile assigned.

All filetypes that don't follow the system default will use their indentation mode no matter what you set in the preferences. Fortunately you can just change it to whatever you like (e.g., None).

share|improve this answer
    
THANK you! That's been driving me bananas. I really appreciate it - that worked beautifully. –  begtognen May 16 '11 at 16:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.