Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After system upgrade to 13.10 there is no GUI at startup. I can login successfully and startx or start lightdm, but it should be done automatically. I tried following these instructions and did:

  • cat /etc/X11/default-display-manager (output: /usr/sbin/lightdm)
  • sudo dpkg-reconfigure lightdm
  • gedit /etc/init/lightdm.conf and before command exec lightdm added sleep 5

Nothing seems to help the situation. How can I fix or debug this?

share|improve this question
Appreciate it, Olli! How can I thank you? – user184566 Mar 11 '14 at 7:23
Have you tried to purge lightdm and then reinstall it? – CameronNemo Jun 3 '14 at 1:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.