Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm currently working on a Ubuntu machine that has been set up by a user using a German keyboard layout. I prefer another one and changed it using the "Keyboard" dialog (I even deleted the old one).

However after each reboot those changes are gone. The German layout has reappeared and is (again) the default one.

How can I make those changes permanent?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Have you clicked System->Preferences->Keyboard->Layouts->Apply System-Wide?

I seem to remember you may need to switch layout on the login screen one more time after that before it sticks.

share|improve this answer
    
That did it. Thanks! –  Chris Oct 2 '10 at 21:29
    
Any particular design reason behind this "workflow"? –  Chris Oct 2 '10 at 21:29
    
I would speculate that the ‘previous selection’ is always remembered and used by default, even going so far as to add it to the menu if it had been removed from the explicit list of layouts. –  bobince Oct 3 '10 at 0:10
    
Bobince is right, AFAIK. You need to switch layout on the login screen for it to stick. –  Tiede Feb 19 '11 at 1:14
    
nice observation! that behaviour is...strange..to put it nicely. The relevant bug is here: bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/… (status fixed is somewhat confusing, though) –  Christoph Jul 27 '11 at 16:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.