Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

NETWORK TOPOLOGY

enter image description here

Whenever I try to transfer files within the local network with scp I can't reach speeds above 2Mb/s, in both direction (server--->laptop or laptop--->server). Same with FTP.

I noticed that the data transfer starts at 2.5[Mb/s] and then quickly drops down to 500[Kb/s] after a few seconds.

The transfer from the server to the laptop is slightly faster (3Mb/s instead of 2Mb/s).

I would expect the speed to be at least 25Mb/s since it is a pure local data transfer.

FYI, some meaningful outputs :

ON THE SERVER

:~$ ifconfig

eth0  Link encap:Ethernet  HWaddr 00:13:d3:cd:8a:7b  
      inet adr:192.168.1.246  Bcast:192.168.1.255  Masque:255.255.255.0
      adr inet6: fe80::213:d3ff:fecd:8a7b/64 Scope:Lien
      UP BROADCAST RUNNING MULTICAST  MTU:1492  Metric:1
      Packets reçus:34893 erreurs:0 :2 overruns:0 frame:0
      TX packets:45145 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 lg file transmission:1000 
      Octets reçus:19810274 (19.8 MB) Octets transmis:57877746 (57.8 MB)

lo    Link encap:Boucle locale  
      inet adr:127.0.0.1  Masque:255.0.0.0
      adr inet6: ::1/128 Scope:Hôte
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      Packets reçus:36 erreurs:0 :0 overruns:0 frame:0
      TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 lg file transmission:0 
      Octets reçus:2160 (2.1 KB) Octets transmis:2160 (2.1 KB)

:~$ sudo ethtool eth0

Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes:  10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                     100baseT/Half 100baseT/Full 
Link partner advertised pause frame use: No
Link partner advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: d
Current message level: 0x00000000 (0)

Link detected: yes

ON THE LAPTOP

$ ifconfig

eth0      Link encap:Ethernet  HWaddr 00:21:cc:d3:8d:67  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
          Interruption:20 Mémoire:f2500000-f2520000 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:1562 erreurs:0 :0 overruns:0 frame:0
          TX packets:1562 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:478231 (478.2 KB) Octets transmis:478231 (478.2 KB)

wlan0     Link encap:Ethernet  HWaddr 60:67:20:bd:5e:4c  
          inet adr:192.168.1.12  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::6267:20ff:febd:5e4c/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1492  Metric:1
          Packets reçus:161831 erreurs:0 :0 overruns:0 frame:0
          TX packets:101552 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:195684887 (195.6 MB) Octets transmis:29360206 (29.3 MB)

sudo iwconfig wlan0

wlan0     IEEE 802.11abgn  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:26:4D:26:A1:2D   
          Bit Rate=54 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=52/70  Signal level=-58 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:3791   Missed beacon:0

Do you know what could be the root cause of this crazy slowness ?

share|improve this question

1 Answer 1

Try this in Terminal

sudo iwconfig wlan0 rate 54M

If you are trying to transfer from laptop on the wireless network

  • you can change wlan0 to what ever the network you need to get edited i think its the wireless :)

please let me know if this helps

share|improve this answer
    
The bit rate of wlan0 is already set to 54 Mb/s (see the output of iwconfig in the question post ;-) ) –  Buddyshot Mar 10 at 10:42
    
Did you check the ftp server settings is it capped or set to unlimited –  Hawk-Tech Mar 10 at 11:45
    
Ultimately, I don't want to use ftp. I am more in favor of sftp. I only used ftp to check if the problem occurs regardless of the service used. Indeed, the slowness happens both with ftp and ssh, so it should not be related to protocol settings. –  Buddyshot Mar 10 at 13:21
    
Can you give your router module info please –  Hawk-Tech Mar 12 at 10:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.