Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed terminator (org.jessies.terminator.i386.deb) on ubuntu 12.04 but after executing it i got this error. "Terminator requires Java 6 or newer.

http://java.sun.com/javase/downloads/ may link to a suitable JRE, if you can't use one provided by your OS vendor"

can anyone help me on this? Farooq

share|improve this question

2 Answers 2

If you are talking about the terminal emulator terminator, it does not need Java and it is installable from the main repositories. This is what you get when installing on a fresh 13.04 install:

terdon@oregano ~ $ sudo apt-get install terminator
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following extra packages will be installed:
  libbonobo2-0 libbonobo2-common libbonoboui2-0 libbonoboui2-common
  libglade2-0 libgnome2-0 libgnome2-bin libgnome2-common libgnomecanvas2-0
  libgnomecanvas2-common libgnomeui-0 libgnomeui-common libgnomevfs2-0
  libgnomevfs2-common libidl-common libidl0 libkeybinder0 liborbit2
  libvte-common libvte9 python-gnome2 python-keybinder python-pyorbit
  python-vte
Suggested packages:
  libbonobo2-bin desktop-base libgnomevfs2-bin libgnomevfs2-extra gamin fam
  gnome-mime-data python-gnome2-doc python-pyorbit-dbg
The following NEW packages will be installed:
  libbonobo2-0 libbonobo2-common libbonoboui2-0 libbonoboui2-common
  libglade2-0 libgnome2-0 libgnome2-bin libgnome2-common libgnomecanvas2-0
  libgnomecanvas2-common libgnomeui-0 libgnomeui-common libgnomevfs2-0
  libgnomevfs2-common libidl-common libidl0 libkeybinder0 liborbit2
  libvte-common libvte9 python-gnome2 python-keybinder python-pyorbit
  python-vte terminator

As you can see in the output above, there is no java or JRE requirement and you can install terminator (which is a python program) directly from the Ubuntu repositories.


There are actually two terminal emulators with the same name. The one you tried to install does indeed need Java and if you are really sure you want that one, despite its being much heavier (java) and complicated to install, you can install a JRE with

sudo apt-get install openjdk-7-jre

I stress however, that installing jre to get a terminal emulator is ridiculous. As far as I can tell both terminator flavors have the same functionality but the one you want to install is simply much much much heavier on the system. Still, your choice.

share|improve this answer
    
I want to install (org.jessies.terminator.i386.deb) –  Farooq Mar 9 at 19:53
    
@Farooq I know, I was suggesting that you install the other one which is just as good and does not need java. Anyway, see updated answer for how to install the jre. –  terdon Mar 9 at 20:13
    
Thanks. Looking forward for right answer for terminator –  Farooq Mar 9 at 20:20
    
@Farooq I just gave you the right answer. My update explains how to install JRE and that is what your terminator is complaining about. –  terdon Mar 9 at 20:22
    
@ Terdon, Fine Thanks –  Farooq Mar 10 at 4:11

I recommend the Oracle version over OpenJDK. Java 7 should work. Installation is described here:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java7-installer
share|improve this answer
    
Axel i tried this but got this error. "root@farooq:/home/administrator# apt-geckages have unmet dependencies: oracle-java7-installer : Depends: java-common (>= 0.24) but it is not going to be installed Recommends: gsfonts-x11 but it is not going to be installed python-all : Depends: python (= 2.7.3-0ubuntu2) but 2.7.3-0ubuntu2.2 is to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). –  Farooq Mar 9 at 19:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.