Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I am using Lubuntu 13.10 32-bit on an old computer. I got the NVIDIA drivers for my GeForce4 MX440 from the official NVIDIA site.

Now I am stuck. If I start the driver setup in LXDE it says I need to stop the display manager. If I start the driver setup from the Recovery mode, it says that the filesystem is read-only (incredibly frustrating)!

How to go into text mode so that I can install the drivers? Also, is there anything else I need to do (like install some extra software)?

share|improve this question

marked as duplicate by Amith KK, Radu Rădeanu, BuZZ-dEE, Avinash Raj, Alvar Mar 13 at 20:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Well in the mean time I learned about Ctrl-Alt-F1 and service lightgdm stop. They are of no help though. The driver setup is asking for the Linux source header module things??? –  user256457 Mar 9 at 16:37
    
Is there really still a driver (let alone many) for Geforce4? Where did you get it? I've looked on nvidia.com/Download/index.aspx?lang=en-us, and the oldest supported card was Geforce5. –  mikewhatever Mar 9 at 16:43
    
@mikewhatever yes GeForce4 is supported as Legacy->GeForce4 MX: here for example. Can you help me more please? How to build the Linux source? –  user256457 Mar 9 at 16:56
    
Make sure you have the linux-headers-generic package installed. It's a so called meta-package, that will always pull in the laters available headers. I've looked at the 96.43.23 release page from 2012, which says "Added support for X.Org xserver versions 1.11 and 1.12.". 13.10 has xserver 1.14, so I am really not sure how well that driver is going to work. If it doesn't, try 12.04 with its 1.11 xserver. –  mikewhatever Mar 10 at 15:44

1 Answer 1

How to install nvidia drivers from source script?

Disable nouveau

  1. open any tty other than GUI by ctrl+alt+f[1-6]
  2. stop lightdm/gdm or whatever is your display manager

    sudo stop lightdm

  3. run the script

    sudo sh NVIDIA----.sh

solving problems

  1. if something goes wrong close the installer and reboot then try again
  2. still same problem the nvidia installer will make a black list in /etc/modprobe.d/
  3. if this is not generated you have to make such file to black list nouveau
  4. Run sudoedit /etc/modprobe.d/nvidia-graphics-drivers.conf and fill it with this: blacklist nouveau
  5. If the problem is not solve you have to add the string "nomodeset" to your /etc/default/grub, in GRUB_CMDLINE_LINUX_DEFAULT= line
  6. then update the grub sudo update-grub
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.