Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem where after recent updates my Wifi stopped working. I can detect my wireless network but when attempting to join it the wifi icon in the task bar just 'rolls' the wifi signal indicator up and down and never actually connects. It would often ask for the password a few times. I've tried changing the Wifi password, restarting the machine, disabling/enabling the wifi adapter, but nothing seems to be working. I can see the network but just can't connect.

Please help. How can I fix this.

I am using: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)

The 14e4 was Orange/red in the report, not sure if that means something?

Anyone know I can can get my laptop to actually connect to the Wifi again?

share|improve this question
    
The answer depends on your Ubuntu version. Please edit your question to add the result of: lsb_release -d –  chili555 Mar 9 at 15:59
    
After doing what Premkumar suggested and the issue still not being resolved; I again went to System Settings > Additional Drivers. There is shows 'Broadcom STA Wireless Driver (grayed out) When I click "activate" it says "Failed to install driver" –  David Venter Mar 9 at 16:00
    
Yes, it is the wrong driver for your device. However, we need to know your Ubuntu version as I asked above in order to propose a solution. –  chili555 Mar 9 at 16:02
    
I have updated the questions title. The version is: Ubuntu 12.04.4 LTS –  David Venter Mar 9 at 16:48
add comment

2 Answers 2

Here solution for your problem user Raj given answer that’s work for me try it

Wifi - wireless network not working after installing Ubuntu 12.04

share|improve this answer
    
Thanks for the feedback but this did not resolve the issue. I still can't connect to the wireless network. –  David Venter Mar 9 at 15:22
add comment

Please open a terminal and do:

sudo apt-get purge bcmwl-kernel-source

Now, with a temporary wired ethernet connection:

sudo apt-get install firmware-b43-lpphy-installer

Detach the ethernet, reboot and let us have your report.

share|improve this answer
    
After restarting I can no longer see 'Wireless Network' in the Network settings or when clicking on the networking icon in the task bar. The physical/hardware wifi button on the compaq is lit up as 'on' but pressing the button to try disable/enable again does nothing, it just stays on even though the wireless networking device isn't listed in network settings. –  David Venter Mar 10 at 6:44
    
I've removed all the drivers again, reset my router to factory settings again, followed your instructions again AND what was previously suggested. Then restarted and now it's working. No idea which driver is being used now and no idea if the wifi router factory reset also helped but I'm glad that it's working now. How to I check which driver is being used so that I can report back here? –  David Venter Mar 10 at 9:24
    
Please check: lsmod. It should be b43. –  chili555 Mar 10 at 11:08
    
Not sure which item on the list is the wireless. I assume this: cfg80211 181041 1 wl - I don't see b43 anywhere. –  David Venter Mar 11 at 11:49
    
If wl is loaded, then you didn't purge bcmwl-kernel-source or you reinstalled it!! Please retrace your steps; try my steps again and tell us the result. –  chili555 Mar 11 at 12:57
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.