Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Xubuntu 12.04 with the xfce 4.10 ppa, and since updating xfce I can not disable the automatic session restore.

I have disabled the relevant options in 'Session and Startup', but it makes no differences and all my windows are still restored after login.

If I remove the content of .cache/sessions it works for the next reboot but after that the session will be restored again.

I thought about writing a script to delete it at startup, but I was wondering if there were any proper fixes to this issue.

Thanks,

share|improve this question
    
Did you have a look at apps->gnome-session->options in gconf-editor whether its enabled there? –  i08in Mar 9 at 10:34
    
not sure what you mean ? I am using xfce, where is this gnome-session ? –  deSitterUniverse Mar 9 at 17:57

2 Answers 2

up vote 1 down vote accepted

Since there are no other suggestions, here is a quick fix for anyone who comes across this thread :

emacs _path_/startup.sh

write in the file

#!/bin/bash

rm -rf /home/_name_/.cache/sessions/*

make it executable

chmod +x _path_/startup.sh

go under 'Session and Startup' and add _path_/startup.sh to the applications automatically executed when xfce opens.

share|improve this answer

It is possible that you have stumbled on a bug related to the Action Buttons. For a discussion of a very similar issue reported recently see:

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.