Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When running Banshee under Unity on Natty (upgraded from Maverick), music plays as expected but when hitting the (x) button on the title bar the window exits and the music stops as well.

share|improve this question

2 Answers 2

When upgrading the banshee extension providing soundmenu integration was not automatically enabled. Enabling this extension allows banshee to show itself in the soundmenu indicator and also to close its window without stopping playback.

To change this option open the preferences dialog box (Edit/Preferences on the menu), and select the Extensions tab. Use the search box to find "sound menu" and ensure that the tick box on the right is selected.

share|improve this answer
    
+1 Note: in contrast to my solution, this will quit Banshee only if not playing music. Anyways, the sound menu extension wasn't enabled on my fresh Natty installation, so this doesn't seem to be default. –  htorque May 16 '11 at 11:45

That's the intended behavior.

However, you can install the banshee-extension-appindicator package and enable the Application Indicator for Banshee via Edit → Preferences → Extension. This will prevent Banshee from quitting when closing its window.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.