Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Please help me out with the below issue

I tried "sudo apt-get install ubuntu-restricted-extras" on 13.10 and it all worked well until something named ttf-mscorefonts installer came. It was not getting downloaded for quite a few minutes .So I quit the process.

Now I am not able to install any software, not from software center. whenever I try with something like sudo apt-get install **** , it shows something like:

neel101@neel101-Inspiron-7520:~$ sudo apt-get install pip
[sudo] password for neel101: 
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to   correct     the problem. 
neel101@neel101-Inspiron-7520:~$ sudo dpkg --configure -a
Setting up update-notifier-common (0.147) ...
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe

and this continues for several minutes....

EDIT I pressed Ctrl+C now and this came

^CTraceback (most recent call last):
  File "/usr/lib/update-notifier/package-data-downloader", line 296, in <module>
    process_download_requests()
  File "/usr/lib/update-notifier/package-data-downloader", line 234, in    process_download_requests
    dest_file = urllib.urlretrieve(files[i])[0]
  File "/usr/lib/python2.7/urllib.py", line 94, in urlretrieve
    return _urlopener.retrieve(url, filename, reporthook, data)
  File "/usr/lib/python2.7/urllib.py", line 268, in retrieve
    block = fp.read(bs)
  File "/usr/lib/python2.7/socket.py", line 380, in read
    data = self._sock.recv(left)
KeyboardInterrupt
dpkg: error processing update-notifier-common (--configure):
 subprocess installed post-installation script was interrupted
dpkg: dependency problems prevent configuration of ttf-mscorefonts-installer:
 ttf-mscorefonts-installer depends on update-notifier-common (>= 0.119ubuntu2);     however:
  Package update-notifier-common is not configured yet.

dpkg: error processing ttf-mscorefonts-installer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of flashplugin-installer:
 flashplugin-installer depends on update-notifier-common (>= 0.119ubuntu2); however:
  Package update-notifier-common is not configured yet.

dpkg: error processing flashplugin-installer (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 update-notifier-common
 ttf-mscorefonts-installer
 flashplugin-installer
neel101@neel101-Inspiron-7520:~$ 
share|improve this question
    
possible duplicate of How can I accept the Microsoft EULA agreement for ttf-mscorefonts-installer? (includes information about how to accept it after rejecting it, when the package is "half installed") –  Eliah Kagan Aug 23 at 6:01

1 Answer 1

up vote 1 down vote accepted

Try the below commands,

sudo apt-get autoremove
sudo apt-get clean 

It will remove all the unused packages.

OR

sudo dpkg -P ttf-mscorefonts-installer
sudp dpkg -P flashplugin-installer
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.