Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to watch R.I.P.D. (a DVD).

  • The DVD is not broken, because I can play it on a friends computer on Windows 7.
  • My DVD player is not broken, as I can play other DVDs (also with double layer) on my computer
  • => It is not a hardware problem.

Codecs

I've installed the following codecs:

sudo apt-get install ubuntu-restricted-extras
sudo apt-get install libdvdread4 libdvdcss2 libdvdcss libdvdnav4
sudo /usr/share/doc/libdvdread4/install-css.sh
sudo apt-get install gstreamer0.10-plugins-ugly gstreamer0.10-ffmpeg libxine1-ffmpeg gxine mencoder libdvdread4 totem-mozilla icedax tagtool easytag id3tool lame nautilus-script-audio-convert libmad0 mpg321

Regionset

$ regionset /dev/dvd
regionset version 0.1 -- reads/sets region code on DVD drives
ERROR: Could not open disc "/dev/dvd"!
Please ensure there is a readable CD or DVD in the drive.

What I've tried

VLC

vlc doesn't play the DVD at all:

$ vlc
VLC media player 2.0.8 Twoflower (revision 2.0.8a-0-g68cf50b)
[0xee3048] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
"sni-qt/3981" WARN  16:09:18.033 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE 
libdvdnav: Using dvdnav version 4.2.0
libdvdread: Using libdvdcss version 1.2.13 for DVD access
libdvdread: Can't stat /dev/dvd
No such file or directory
libdvdread: Could not open /dev/dvd
libdvdnav: vm: failed to open/read the DVD
libdvdread: Using libdvdcss version 1.2.13 for DVD access
libdvdread: Can't stat /dev/dvd
No such file or directory
libdvdread: Could not open /dev/dvd
[0x7f2060001168] dvdread demux error: DVDRead cannot open source: /dev/dvd
[0x7f2074000b78] main input error: open of `dvd:///dev/dvd' failed

Banshee

banshee plays the intro, but crashes within the first seconds of the movie:

libdvdread: Get key for /VIDEO_TS/VTS_04_1.VOB at 0x000047c1
libdvdread: Elapsed time 0
libdvdread: Found 4 VTS's
libdvdread: Elapsed time 0

** (Banshee:4512): CRITICAL **: bp_get_subtitle_description: assertion 'code != NULL' failed
[Info  16:14:19.926] Inhibiting screensaver during fullscreen playback

** (Banshee:4512): CRITICAL **: gst_video_decoder_allocate_output_frame: assertion 'frame->output_buffer == NULL' failed
[Error 16:14:51.027] GStreamer stream error: Failed

(Banshee:4512): GStreamer-CRITICAL **: gst_element_query_position: assertion 'GST_IS_ELEMENT (element)' failed

(Banshee:4512): GStreamer-CRITICAL **: gst_element_seek: assertion 'GST_IS_ELEMENT (element)' failed

(Banshee:4512): GLib-GObject-CRITICAL **: g_object_get: assertion 'G_IS_OBJECT (object)' failed

(Banshee:4512): GLib-GObject-CRITICAL **: g_object_get: assertion 'G_IS_OBJECT (object)' failed

xine

Does not work at all:

$ xine
This is xine (X11 gui) - a free video player v0.99.7.
(c) 2000-2010 The xine Team.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
vo_vdpau: Can't create vdp device : No vdpau implementation.
libdvdread: Using libdvdcss version 1.2.13 for DVD access
libdvdread: Can't stat /dev/dvd
No such file or directory
libdvdread: Using libdvdcss version 1.2.13 for DVD access
libdvdread: Can't stat /dev/dvd
No such file or directory

Other information

When I insert the DVD, I get:

$ dmesg | tail     
[   31.247778] vboxdrv: fAsync=0 offMin=0x34c offMax=0x142c
[   31.247885] vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
[   31.247886] vboxdrv: Successfully loaded version 4.2.16_Ubuntu (interface 0x001a0005).
[   31.292926] vboxpci: IOMMU not found (not registered)
[   35.064449] init: plymouth-stop pre-start process (1734) terminated with status 1
[   42.824129] Adding 3854332k swap on /dev/mapper/cryptswap1.  Priority:-1 extents:1 across:3854332k FS
[  109.823293] UDF-fs: INFO Mounting volume 'R.I.P.D.', timestamp 2013/09/06 16:17 (103c)
[  743.918140] perf samples too long (2507 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
[ 2919.903058] perf samples too long (5006 > 5000), lowering kernel.perf_event_max_sample_rate to 25000
[ 9509.139752] UDF-fs: INFO Mounting volume 'R.I.P.D.', timestamp 2013/09/06 16:17 (103c)
share|improve this question

closed as off-topic by Mateo, hbdgaf, Avinash Raj, Braiam, karel Mar 14 at 6:53

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Mateo, Avinash Raj, karel
  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – hbdgaf, Braiam
If this question can be reworded to fit the rules in the help center, please edit the question.

2  
I've seen this happen for other specific DVDs and not others. In most cases, it's either error skipping or menu parsing. I would report the specific DVD that doesn't work to the mostly working package makers/maintainers so they can "see" the error. It's hard to fix something you can't see. –  hbdgaf Mar 8 at 17:08
    
vlc and xine are not finding the DVD drive. How are you attempting to open the DVD? Does it work if you point them to the right place? –  terdon Mar 8 at 17:09
2  
To "describes a problem that can't be reproduced" close-voters: If you think this should be closed, I recommend commenting to explain why. The went-away-by-itself off-topic sub-reason appears inapplicable here because there are enough details in the question for someone with the same problem to find this and be helped by the solution the OP posted. I agree with hbdgaf about reporting this to developers but it's not clearly a bug either. If we close this it should be as a duplicate of some question about the same problem, if there is one. –  Eliah Kagan Mar 8 at 17:10
2  
I understand but the message is that /dev/dvd was not found. I am guessing your dvd device is actually something else. Try /dev/dvd0 for example, or simply look at dmesg | tail after you insert the DVD. –  terdon Mar 8 at 17:38
    
@terdon: That was actually the problem! Thank you! –  moose Mar 8 at 17:50

1 Answer 1

Kaffeine

I finally tried kaffeine. It worked.

VLC

The problem with vlc was that I have simply pressed the play button without checking if the location (which is /dev/dvd per default) was correct.

You can check it like this:

$ cat /proc/sys/dev/cdrom/info | grep "drive name"
drive name:     sr0

Just set /dev/sr0 (or whatever is your output) in "Disk device" and it workes fine.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.