Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had recently run a script in our college exam on my computer which was specifically for 32bit(i386) but my ubuntu is amd64 , so the script wouldn't run but then I tried accessing the folders in my home folder which gave me permission denied. So I did a sudo chmod 777 -R /home/username , which gave me permissions to complete the test even though I was put as an exception to take my test without using the script to run successfully. After all this and another two days later I started facing problems of less space on my drive but I probably should have had plenty of space. Then it said that I have 1.4 kb space left on the system. I searched for my problem on the net and somewhere I found an answer on askubuntu which I am not able to find again. It said that, what actually happened is that the home directory should have 644 permission rather than 777 and so the files I deleted had their INODES still present along with the new files I added to the directory and hence there is no space left. I have removed everything from the home directory and when I try to add a file with size less than a kb it still says no space left. Any help or suggestions will be appreciated.

 running df  gives
    Filesystem     1K-blocks      Used Available Use% Mounted on
    /dev/sda6       16229452  15634864         0 100% /
    udev             1941220         4   1941216   1% /dev
    tmpfs             780000       972    779028   1% /run
    none                5120         0      5120   0% /run/lock
    none             1949996      9732   1940264   1% /run/shm
    overflow            1024       668       356  66% /tmp
    /dev/sda3      449082364 281834708 167247656  63% /media/Acer
    /dev/sdb1      976762524 250648068 726114456  26% /media/HD-PCTU2

df -h

Filesystem      Size  Used Avail Use% Mounted on
/dev/sda6        16G   15G     0 100% /
udev            1.9G  4.0K  1.9G   1% /dev
tmpfs           762M  972K  761M   1% /run
none            5.0M     0  5.0M   0% /run/lock
none            1.9G   14M  1.9G   1% /run/shm
overflow        1.0M  668K  356K  66% /tmp
/dev/sda3       429G  269G  160G  63% /media/Acer
/dev/sdb1       932G  240G  693G  26% /media/HD-PCTU2

gparted Image

i.imgur.com/NK0U349.png
share|improve this question
    
post the output of df -h? –  Avinash Raj Mar 8 at 4:58
    
It would be better if you upload gparted screenshot.Take a screenshot and then upload it to imgur.com.Finally post the uploaded link here. –  Avinash Raj Mar 8 at 5:02
    
I don't have space to save a screen shot :( –  RED Mar 8 at 5:03
    
is there any possiblities to take the screenshot by mobile and upload it here. –  Avinash Raj Mar 8 at 5:06
    
Avinash, can you please let me know of what thing I should take a screenshot of. I don't what is gparted and what it is used for. I am some how able to install packages but not able to add any file anywhere. –  RED Mar 8 at 5:10

2 Answers 2

To increase the size of /dev/sda6 root partition,

  • Boot Ubuntu live disk and click on try Ubuntu option on startup.Now open gparted partition Editor from dash.And make sure that all the partitions are unmounted.

  • shrink /dev/sda3 by right-clicking on it and select Resize/Move option.

  • After shrinking, the unallocated space will be created just below to the /dev/sda3 partition.

  • Now right-click on the extended partition and select Resize option to add up the unallocated space by extending the dragger.

  • Unallocated space will comes under extended partition(just below to the /dev/sda5 partition.

  • Rightclick on the /dev/sda5 partition and select Resize/Move option.Move the dragger to extreme right and then click on Apply,so that the unallocated space comes just below to the /dev/sda5 partition.

  • Now you can be able to extend your /dev/sda6 root partition.

See also How to extend ext4 with gparted? and Extending my Root Paritition

share|improve this answer
    
I figured out the problem few days earlier,it was related to the hadoop log files which occupied enormous space. Just needed to clean those. I did increase my partition size. Your answer was useful to some extent. I did want to give a +1 but it requires me 15pts.Thanks for helping. –  RED Mar 13 at 23:20
    
@RED please post your comment as an answer.it will help others in future. –  Avinash Raj Mar 13 at 23:34
up vote 0 down vote accepted

The problem was caused because of a log file taking up too much space on the disk. The file was found in the HADOOP_LOG_DIR. We can find it in /etc/hadoop/conf/hadoop-env.sh. Here while configuring we setup the HADOOP_LOG_DIR.

I found them using:
find / -size +100M -ls.

Just do an rm -rf /var/log/hadoop/ . If your HADOOP_LOG_DIR points to /var/log/hadoop/ else rm -rf that particular location.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.