Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Upon updating my 10.10 netbook to 11.04 on the first startup it froze. I checked the forums and found that disabling wlan in BIOS fixes the problem so I did that and it worked, system was ok and it didn't freeze but then I had no wireless.

I know that Broadcom STA driver is to blame cause I removed it from "additional drivers" and enabled back in bios wlan and everything worked fine (exept no wireless cause no driver is activated).

Enabling Broadcom STA in the additional drivers again and restarting wireless was up and it found my network and connected to it but in a matter of seconds netbook froze.

Can you please help me...

share|improve this question

closed as off topic by Marco Ceppi Feb 4 '12 at 21:06

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Take a look at this Q&A, especially down towards the end with the link regarding blacklisting. –  boehj May 16 '11 at 8:11
This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro Feb 4 '12 at 20:05

1 Answer 1

I would always recommend remove all the old sta packages and reinstalling as you have a new linux kernel

In a terminal, do:
sudo apt-get purge bcmwl-kernel-source
then do
sudo apt-get install bcmwl-kernel-source

This will then rebuild your driver for your NEW kernel

Let us know how you get on

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.