Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently updated my Wubi install form 10.10 to 11.04.
This had problems, so I finally took the plunge and gave Ubuntu its own partition.
It all seemed to go very well (I even got a purple bootscreen which was very exciting the first time).

However, whenever I try to enter Windows XP, I get a flashing horizontal line for a second.
Then it disappears, and I return back to Grub.

Is there a way to get GRUB to load Windows XP? What additional information if any is required?

share|improve this question
    
Welcome to AskUbuntu! Please make sure you put a blank line between paragraphs. Thanks! –  jmendeth May 16 '11 at 16:24
add comment

2 Answers 2

by the way, you should put (#) in the begining of the line , not in front of the line as you said.


anyway....

you have to install ubuntu on its own partition alongside windows or delete windows OS. and install ubuntu on the first partiton (sda1).

but before to do anything, backup your data & make sure to check your hard disk and do defragment for all the harddisk partitions :read this


first, you need to fix the MBR with a bootable winxp CD to restore winxp OS.
boot off a WINXP-CD and when the menu loads, press "R" to go to a command prompt, Once there, choose which partition you want (usually is 1), and enter an admin password (if any).

and then run these commands :

fixboot
fixmbr
exit

after that we need to restore ubuntu boot-loader too:

01 - boot off your Ubuntu-LiveCD (try without install)

02 - open Terminal type:

sudo -i

03 - then type:

fdisk -l

04 - if you have just one harddisk on your PC you will got something like this, ex; on an old PC:

fdisk -l
Disk /dev/sda: 40.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xf6edf6ed
Device Boot Start End Blocks Id System
/dev/sda1 * 1 1217 9775521 7 HPFS/NTFS
/dev/sda2 1218 4866 29306401 f W95 Ext’d (LBA)
/dev/sda5 1218 2434 9775521 7 HPFS/NTFS
/dev/sda6 2435 3650 9765888 b W95 FAT32
/dev/sda7 365 3772 972800 82 Linux swap / Solaris
/dev/sda8 3772 4866 8786944 83 Linux

05 - mount ubuntu partition:

mount /dev/sda8 /mnt

06 - install grub2 on MBR section in 'sda' (the best place) do not install it on the partiton. ex: 'sda1':

grub-install --root-directory=/mnt/ /dev/sda

07 - if no errors appear that means everything is OK :

reboot

08 - return to ubuntu OS & open Terminal and type:

sudo update-grub

now, Ubuntu sure recognise windows OS and add it to grub menu

that's all

:-)


PS: my english isn't good , if I made a mistake , please correct it .

share|improve this answer
add comment

According to this post: http://ubuntuforums.org/showthread.php?t=1195275 The GRUB_HIDDEN_TIMEOUT_QUIET is not working right. do a :

sudo nano /etc/default/grub

and take a look at this setting:

GRUB_HIDDEN_TIMEOUT

Edit: Make sure that the following is not commented out and is true.

GRUB_HIDDEN_TIMEOUT_QUIET = true
share|improve this answer
    
thanks for your response @capdragon. what value should this contain? –  Commander jao May 17 '11 at 12:02
    
Check my edit... i meant (GRUB_HIDDEN_TIMEOUT_QUIET) make sure it's not commented out and is true. see if that works. –  capdragon May 17 '11 at 15:15
    
it is already set to true. What now? –  Commander jao May 18 '11 at 7:58
    
If it's set to true and it's not commented out (has '#' in front of it) then this is not your answer. –  capdragon May 18 '11 at 14:35
    
unfortunately no such luck the # out the front seemed to make no difference. would re-imaging the laptop, so it just had XP and then partitioning again fix the problem? –  Commander jao May 22 '11 at 5:03
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.