Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just tried to install the Perl module XML::LibXML::Document using the cpan shell and at the end of the process it says:

Please use 'update-perl-sax-parsers(8) to register this parser.'
See /usr/share/doc/libxml-sax-perl/README.Debian.gz for more info.

If I run update-perl-sax-parsers with no arguments it returns almost instantly with no output (and I still can't use XML::LibXML::Document within Perl)

If run 'update-perl-sax-parsers -help' I can see I probably need to specify the --directory flag or the --file (although they have defaults)

Perhaps I missing something but I can't see where in README.Debian.gz it tells me what options I need either.

What step am I missing?

I'm running on Ubuntu 12.04, Perl 5.14, CPAN shell v1.960001

Let me know if this is more suited to stackoverflow.

share|improve this question
    
Does man update-perl-sax-parsers get you anything useful? –  Powerlord Mar 7 at 15:52

1 Answer 1

up vote 1 down vote accepted

XML::LibXML::Document is just a XML::LibXML DOM Document Class.

You can't use it directly, only use XML::LibXML; is required.

first type sudo update-perl-sax-parsers --update

An you can quickly check that the following command works:

perl -e 'use XML::LibXML; $dom = XML::LibXML::Document->new( $version, $encoding );'
share|improve this answer
    
Great, thanks. The problem was a combination of me trying to use the Document class directly, plus (I don't think) the docs for update-perl-sax-parsers are very clear. I'll see if I can suggest a change. –  Disco 3 Mar 11 at 9:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.