Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've looked at the other questions about having problems connecting to the internet, but it hasn't worked for me so far.

I bought a netbook and I wanted to try Ubuntu out, which I installed from a usb. So I installed it, replacing the windows7 that came with it, and now it doesn't connect to the internet (it did connect when it was windows). I've run some of the more basic steps, and have tried to install some dkms from the pool files, but it won't let me install anything.

I don't know the commands that well, so I can't say that I'm doing things correctly, so if anyone could please walk me through this - I'd be much obliged.

It also doesn't recognize an ethernet cord.

Using Ubuntu 3.11.0-15-generic lts-saucy BCM4312 [14e4:4315]

share|improve this question
    
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Danatela Mar 7 at 5:49
    
Unfortunately, the answers given in the 'duplicate of' are conflicting and, in many cases, incorrect. Please un-duplicate so I may give a correct answer. –  chili555 Mar 7 at 14:16
    
@chili555: That seems to a canonical question concerning Broadcom drivers. It would be preferable if you post the answer over there. If your answer is just for BCM4312, state that fact. I don't see reasons to reopen this question. –  Aditya Mar 7 at 14:45
    
@Aditya I am working on a massive edit for that 'duplicate of' with Luis Alvarado. In the meantime, users are referred to a confusing and downright incorrect location. Please reopen so at least user255666 gets an answer he can use. –  chili555 Mar 7 at 16:51
    
@chili555 Alright, I have nominated it to Reopen... we might close and merge it lateron :-) –  Aditya Mar 7 at 17:14

1 Answer 1

The Broadcom 14e4:4315 is quite unusual in that the solution changes from earlier Ubuntu versions to later. In Ubutnu 13.10, which you are using, the device uses the native b43 driver and firmware that needs to be downloaded separately. Please first try to undo any possibly failed previous attempts; open a terminal and do:

sudo apt-get purge bcmwl-kernel-source

If the terminal reports that it was not installed so not removed, that's fine, please continue. Get a temporary wired ethernet connection and do:

sudo apt-get install linux-firmware-nonfree

Detach the ethernet, reboot and let us hear your report.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.