Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having trouble loading ecb at emacs startup.

d@d:$ apt-file search ecb.el
ecb: /etc/emacs/site-start.d/55ecb.el
ecb: /usr/share/emacs/site-lisp/ecb/ecb.el
emacspeak: /usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-ecb.el
xemacs21-basesupport: /usr/share/xemacs21/xemacs-packages/lisp/ecb/ecb.elc
xemacs21-basesupport-el: /usr/share/xemacs21/xemacs-packages/lisp/ecb/ecb.el.gz

my .emacs file:

(add-to-list 'load-path "/usr/share/emacs/site-lisp/ecb/")
(require 'ecb)

What am I doing incorrectly?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

If you're not getting any errors, you probably just need:

(ecb-activate)

after those lines.

share|improve this answer
add comment

What you've done is not necessary: the Ubuntu package contains everything that's needed to make the list packages available to Emacs instances. All you need to do is enable the features you want. This has to be done on a per-user basis so as not to annoy the users who don't want those features. In the case of ecb, if you want it active all the time, call (ecb-activate) in your .emacs. If you want a more complex set up, read the “Installation and first steps” chapter in the ecb manual, but skip the “Installation” section which the distribution has already done for you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.