Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

[SOLVED] I managed to fix the issue by uninstalling the proprietary AMD drivers, rebooting, starting Steam letting it update, reinstalling AMD drivers, reboot. It seems to be working and I can now play all my Steam linux games.

I just installed Ubuntu 13.10 64bit on my main PC. I also installed Steam (.deb from Steampowered.com). The install went without errors.

On running Steam, nothing happens. I run Steam from the terminal and receive two segmentation faults, always occurring on different lines of Steam.sh when I run Steam:

/home/samathy/.local/share/Steam/steam.sh: line 755: 11111 Segmentation fault  
/home/samathy/.local/share/Steam/steam.sh: line 755: 11239 Segmentation fault 

The rest of the output on the terminal is just dump-saving text. I can't see anything about GLX issues, or locale issues (they seem to be popular issues with steam)

I'm running Ubuntu 13.10 64bit with Xubuntu (installed after the Ubuntu install.) My specs are as follows:

AMD FX 6350. AMD HD7870 (With AMD proprietary beta drivers) 12GB DDR3 Samsung 840 EVO 120GB.

This problem is a little weird to me because Steam runs fine on my Ubuntu 13.10 + Xubuntu-desktop, Intel Atom N270 netbook without any fiddling, I can even run games.

I've googled a lot and only really found solutions to other steam issues, not my own.

If anyone could help, that'd be wonderful. Thanks!

edit: I should mention that I've tried doing

~$steam --reset

It does not produce errors its self, but also doesnt solve the problem either. I have also tried installing Steam from Ubuntu package manage, but that results in the same errors.

share|improve this question

closed as off-topic by Jorge Castro, BuZZ-dEE, waltinator, Sylvain Pineau, Avinash Raj May 27 at 13:14

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – waltinator, Avinash Raj
  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Jorge Castro, BuZZ-dEE, Sylvain Pineau
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

I can also confirm this happening with Catalyst 14.3 Beta installed on a clean Saucy install.

I'll try removing it and then letting Steam download.

On my laptop (same exact setup, only didn't install Catalyst yet), Steam starts.

Edit: Confirmed working on my laptop and desktop. So if doing a clean install of Saucy, install and update Steam before installing Catalyst.

share|improve this answer
    
removing Catalyst worked for me –  niccomatik Aug 3 at 23:19

I renamed my steam directories and tested here with nvidia + bumblebee.

I can confirm that I see the same segmentation faults. :(

Line 755 seems to be right where it fires off the steam binary.

Starting the binary manually, I see "Fatal Error: Failed to load steamui.so".

ldd shows it finding everything... except files in its own directory (such as libSDL2-2.0.so.0). That's weird, because I expected it to be failing to find something like libGL.so.1 - but that's found fine.

Renaming my old directories back, steam runs fine.

So, something's seriously SNAFU with Valve's installer on 13.10/14.04.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.