Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A particular PDF I have uses a non-embedded font named "TimesNRMT" that is not installed on my system. Instead of substituting the font with a similar one such as Times New Roman, Document Viewer is inappropriately choosing to use some sans-serif font, which makes the text nearly unreadable:

screenshot

How can I override this choice of font substitution?

share|improve this question

2 Answers 2

up vote 9 down vote accepted
+50

Create a rule in your .fonts.conf file. If it's not in your home folder, create it. Here's a full example of a .fonts.conf file:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

  <match target="pattern" name="family" >
    <test name="family" qual="any" >
      <string>TimesNRMT</string>
    </test>
    <edit name="family" mode="assign" binding="same">
      <string>Times New Roman</string>
    </edit>
  </match>

</fontconfig>

If you already have the file, just paste in the part enclosed by the match tags.

If you're using Font Manager the file is in a different place(~/.config/font-manager/local.conf).

share|improve this answer
    
Are you recommending that I just disregard the giant DO NOT EDIT THIS FILE warning at the top? –  ændrük Jun 2 '11 at 19:32
1  
Not really, I've done similar substitutions in my local .fonts.conf. I'm editing my answer. Silly of me to think it's obvious which file I was talking about. Sorry. –  miloshadzic Jun 2 '11 at 19:51
    
Thanks, this is just what I needed. I chose to use alias to keep it simple. ~/fonts.conf. –  ændrük Jun 8 '11 at 14:52

Maybe you’ll need to install MS Core Fonts.

sudo apt-get install msttcorefonts
share|improve this answer
    
A better option would be to install Red Hat's Liberation fonts, which are near equivalents of popular Microsoft fonts, and substitute them as susggested by miloshadzic. –  Subhash Jun 6 '11 at 11:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.