Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Ubuntu 12.04 installed, running Gnome 3, and yesterday I installed Pepper Flash. Ever since Chrome has been locking up on different webpages. At first it was strictly Youtube but now it seems to be others sites also. Anything with any type of flash or heavy scripting.

I would be comfortable with Chromium crashing and simply reloading it. But when it crashes, it locks up my whole session and even after entering the terminal (CtrlAltF1), and killing all the Chromium processes it still shows a frozen screen with Chromium up. I can see my mouse pointer move up on the top menu bar, but the Gnome interface is unresponsive as well.

I am a total newbie to troubleshooting Linux. What else can I do to get my session back without rebooting my box?

Also where can I check the logs to see if Pepper Flash is my issue?

share|improve this question
Chrome or chromium? Its confusing – i08in Mar 6 '14 at 18:01
@SeanLeftBelow I'm not sure that Pepper flash causes the problem.<br> I have also google crhome crash on Ubuntu 12.04 independently of the webpages that is opened.<br> I then open chrome from the terminal with google-chrome --disable-gpu command.<br> It seems to avoid crashes. But i think that it's very ennoying to open it every time like that. – user255862 Mar 7 '14 at 17:15

You can try disabling pepper flash in chromium plugins chrome://plugins/. If the problem persists it's not pepper. Though I don't think pepper can cause such a desktop issue.

You may also try using google-chrome and see if things change. Its default flash plugin might work.

Linux troubleshooting starts with /var/log/syslog - the log file for your desktop. Check it to figure out what happened.

share|improve this answer
All is well, but how do I get my session back without rebooting the box? – SeanLeftBelow Mar 6 '14 at 20:01
@SeanLeftBelow Try export DISPLAY=:0 and then sudo service gdm restart. – Seth Mar 7 '14 at 3:49
@Seth, I did actually just that. I found someone to help in the #gnome IRC and they had me run;<br/> strings /proc/$(pidof gnome-session)/environ | grep DBUS strings /proc/$(pidof gnome-session)/environ | grep DISPLAY which didn't really fix my issue until I did an export on their outputs. Then a gnome-shell --restart which left me with a giant black screen. After some further discussion we realized the issue might be with my video card drivers. I replaced my video card and I will continue to test to see if it fixes the issue. – SeanLeftBelow Mar 7 '14 at 4:13
@SeanLeftBelow sorry, was unavailable. When you are completely locked out (the machine is not responding to changing ttys or any other method), you may try sshing from another machine and restart your session. This will save you a reboot. Btw, was the issue resolved? – Sudhanshu Mar 12 '14 at 6:14
@Sudhanshu, I was able to SSH in and try some commands to get the session rebooted and had no luck. – SeanLeftBelow Mar 13 '14 at 19:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.