Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I checked System Monitor to see if the frequency of my CPU increases without doing anything and saw that xorg is always using 10-40% of the CPU even if it's not doing much of anything on the desktop or simply surfing the Internet. Is this normal? If not, how can I fix it?

I have:

  • a Macbook white 4,1
  • Core2 Duo running at 2.10 GHz
  • GPU Intel GMA X3100
  • 4GB of RAM
  • Ubuntu 11.04

I am running Unity and I do not have many effects enabled. I have only activated Compiz animations, scale, desktop, some shadows...

share|improve this question
add comment

4 Answers

Actually, the System Monitor itself is a rather graphics intensive application, which makes your claim of not doing anything slightly odd. Try running 'top' instead, but ultimately, xorg will probably use less cpu if compiz is off.

share|improve this answer
    
+1 - System Monitor uses a fairly large amount of resources and will likely skew your results. –  Nathan Osman Jul 27 '11 at 19:26
3  
No matter how intensive System Monitor is, having xorg taking up 10-40% of the cpu is not normal at all. My - although more powerful by a rather noticeable difference - system has never seen xorg use more than 2-3%. Right now, for example, Xorg sits between 0 and 1 %. –  Chriskin Jul 27 '11 at 20:06
add comment

40% doesn't seem to be normal. However, how you are measuring this? Are you using top command? Can you also check the output of vmstat command and see how much cpu utilization?

share|improve this answer
add comment

I'm also facing this problem. Xorg ~10%-40% sometimes 50%. Compiz has ~3-5% then.

  • Intel C2D 1,6Ghz, 3GB Ram,
  • Nvidia 8400M GS,
  • Newest Nvidia drivers (295.33). Seems that hardware acceleration is enabled,
  • No Xorg.conf modifications.

Any idea what should i check to find the cause? Which logs should be helpful?

share|improve this answer
    
Right now i'm pretty sure, it's google chrome's fault... –  Simon Mar 26 '12 at 17:06
    
You might be onto something there. I have the same problem with Version 23.0.1271.10. –  onse Oct 21 '12 at 18:40
add comment

I believe you are experiencing this bug:

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/803943?comments=all

It is the most annoying thing in Precise and everyone is waiting for a fix...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.