Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running 13.10 32-bit with connman_1.15-0ubuntu2_i386.deb, iptables (1.4.18-1.1ubuntu1), libxtables10

Connman fails and when I try to restart it I get the following error -

/usr/sbin/connmand: error while loading shared libraries: libxtables.so.7: cannot open shared object file: No such file or directory

I contracted this problem about 2 weeks ago when I accepted an upgrade. Any ideas? Its depressing me.


I found a solution but I cannot answer my own question for 8 hours and so I add it here. If someone can review it then I will appreciate it.

So I don't know why or how I got into this missing dependency problem that was last reported for Wheezy and I am most confused how no one else hit the same, but I have fixed it by recompiling connman.

Here is the steps I followed. If I messed up then please advise but "it worked for me" - famous last words -

build nettle required by gnutls

Seems if you dont install gmp first then nettle will build but you get problems later. I also downloaded p11-kit for good luck.

 sudo apt-get install libgmp-dev 
 sudo apt-get install p11-kit-dev

gnutls complained that it needed version 2.7 of nettle. The newest version of nettle is not compatible. Versions will change. Its cool that the config of gnutls states the version it needs. Watch out for this. As a kid I was always getting stung by nettles. Perhaps now will be no different. doh!

 wget http://www.lysator.liu.se/~nisse/archive/nettle-2.7.tar.gz
 tar zxvf nettle-2.7.tar.gz
 cd nettle-2.7
 autoreconf -i
  ./configure --enable-shared 
 make sudo make install

gnults will complain about a missing root key. I calmed its nerves via the following -

sudo apt-get install unbound-anchor
sudo mkdir /etc/unbound unbound-anchor -a "/etc/unbound/root.key"

build gnutls

download source from www.gnutls.org/

cd gnutls-<version>
sudo make install

build connman

sudo apt-get install xtables-addons-common
sudo apt-get install xtables-addons-dkms
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
sudo make install

After all this I found that the libgnutls gets installed in usr/local/lib but it appears that this is not in the library path and so I created the following symbolic link to fix it. Should /usr/local/lib be in the standard search path? Hmm.

 sudo ln -s /usr/lib/libgnutls.so.28 /usr/local/lib/libgnutls.so.28

Now I can restart connman and on reboot it no longer crashes. cool.

share|improve this question
Did you have a look at this: bugs.debian.org/cgi-bin/bugreport.cgi?bug=691180 ? –  i08in Mar 6 '14 at 11:48
yes. It is the same symptoms but for Wheezy and iptables It seems to be reported as fixed prior to 13.10 or at least that is my guess. –  user255356 Mar 6 '14 at 12:25
I will try rebuilding iptables from source or maybe I should rebuild connman first as it has the dependency issue. Ho hum. –  user255356 Mar 6 '14 at 12:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.