Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The GRUB timeout is 8 seconds. Can this be turned down to 2 or 3 seconds? What is the best way to do this?

share|improve this question
add comment

5 Answers 5

up vote 21 down vote accepted

Try

sudo nano /etc/default/grub

change the GRUB_TIMEOUT value to 2 or 3

save

sudo update-grub
share|improve this answer
add comment

for this you have to change the value of GRUB_TIMEOUT value to 2 or 3 .

1 - go to super mode

su -

followed by typing your root password

2- now open the GRUB.cfg file either in vi editor or Gedit (Gedit is easy (GUI))

vi /boot/grub2/grub.cfg

or

gedit /boot/grub/grub.cfg

3 - then find GRUB_TIMEOUT and change it's value 2 or 3

4 - save the changes

5 - if find any difficulty then watch my video on youtube . click here to watch the video

share|improve this answer
add comment

You might try installing a GUI interface startup manager called "Grub Customizer".

Doesn't look like it's in the repos though. But you can find it here at Launchpad: Grub Customizer

Once installed, boot into Ubuntu, start Grub Customizer and configure it for 0 countdown. Then when you boot there should be no wait.

share|improve this answer
add comment

Not sure if I have a complete answer as I have a few more questions.

First - Permissions: you would normally need sudo to edit grub.cfg. If I'm editing from the commandline, I like nano, which is installed by default, so I would use

$ sudo nano /boot/grub/grub.cfg

If you haven't used nano before, once you're done editing use Ctl-O (the letter) to save and then Ctl-X to exit (the Ctl-O is optional, Ctl-X will prompt if there were changes)

Second - Grub: Editing /boot/grub/grub.cfg is probably not the way to go. Grub2 uses the file /etc/default/grub to get all its options and then generates grub.cfg for you. This is important, because grub.cfg gets updated when there's a kernel update or other things that might affect grub. So if you want your changes to stick you need to edit /etc/default/grub.

$ sudo nano /etc/default/grub
$ sudo update-grub2

More on grub here: https://help.ubuntu.com/community/Grub2/

REMEMBER TO MAKE A BACKUP BEFORE YOU CHANGE SYSTEM FILES :D

Third - 10s wait: I'm not actually sure that grub is your villain here, but hopefully the above will help you figure out if it is. Alternatively, can you elaborate a little more. Are you in the grub menu when you "select Ubuntu to boot?" what happens once you've selected it? Or are you referring to the grub picking a default OS - in that case /etc/default/grub will help.

share|improve this answer
    
Thanks, excellent and detailed answer! –  DUKE May 30 '12 at 13:44
1  
Editing grub.cfg with Grub2 is a bad idea period. And of coursE Grub is the "villain" responsible for the 10 sec default timeout on multiple-boot systems!! –  izx May 30 '12 at 14:00
add comment

A GUI method is to install StartUpManager:

$ sudo apt-get install startupmanager

You can set the Grub2 timeout using this utility.

share|improve this answer
2  
startupmanager often causes problems with grub2 –  con-f-use May 18 '11 at 17:04
2  
and is not available in Ubuntu 12.04's repositories. –  tsusanka May 27 '12 at 14:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.