Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Apt-get is broken for unresolved dependencies. I follow other answers and I do:sudo apt-get -f install I get

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  account-plugin-generic-oauth appmenu-qt5 dbconfig-common gnome-control-center-unity hud indicator-bluetooth libaio1 libavcodec53 libavformat53 libavutil51 libbamf3-1 libcdr-0.0-0
  libclucene-contribs1 libclucene-core1 libcmis-0.3-3 libcolorhug1 libcolumbus0-0 libcolumbus0-0-common libdbusmenu-qt5 libdc1394-22 libdvdnav4 libdvdread4 libexttextcat-2.0-0 libgexiv2-2
  libgsm1 libhaml-ruby1.8 liblangtag-common liblangtag1 libmemcached6 libmspub-0.0-0 libnux-4.0-0 libnux-4.0-common libopencv-core2.4 libopencv-highgui2.4 libopencv-imgproc2.4 libqt5core5
  libqt5dbus5 libqt5gui5 libqt5widgets5 libschroedinger-1.0-0 libsqlite0 libswscale2 libtbb2 libva1 libvisio-0.0-0 libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0
  libxcb-sync0 linux-headers-3.8.0-23 linux-headers-3.8.0-23-generic linux-image-3.8.0-23-generic linux-image-extra-3.8.0-23-generic python-central python-kaa-base python-kaa-metadata
  python-oneconf python-sqlite python-support python-xlib ruby-haml systemd-shim
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  linux-image-extra-3.8.0-35-generic
The following NEW packages will be installed:
  linux-image-extra-3.8.0-35-generic
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 30.7 MB of archives.
After this operation, 96.1 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://security.ubuntu.com/ubuntu/ raring-security/main linux-image-extra-3.8.0-35-generic i386 3.8.0-35.50 [30.7 MB]
Fetched 30.7 MB in 44s (686 kB/s)                                                                                                                                                                 
(Reading database ... 395476 files and directories currently installed.)
Unpacking linux-image-extra-3.8.0-35-generic (from .../linux-image-extra-3.8.0-35-generic_3.8.0-35.50_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/linux-image-extra-3.8.0-35-generic_3.8.0-35.50_i386.deb (--unpack):
 trying to overwrite '/lib/modules/3.8.0-35-generic/kernel/arch/x86/platform/iris/iris.ko', which is also in package linux-image-3.8.0-35-generic 3.8.0-35.52~precise1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.8.0-35-generic /boot/vmlinuz-3.8.0-35-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.8.0-35-generic /boot/vmlinuz-3.8.0-35-generic
Errors were encountered while processing:
 /var/cache/apt/archives/linux-image-extra-3.8.0-35-generic_3.8.0-35.50_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

relevant info uname -r 3.8.0-35-generic

cat /etc/apt/sources.list

# deb cdrom:[Ubuntu 12.10 _Quantal Quetzal_ - Release i386 (20121017.2)]/ quantal main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://us.archive.ubuntu.com/ubuntu/ raring main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ raring main restricted

## Major bug fix updates produced after the final release of the
## distribution.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ raring universe
deb-src http://us.archive.ubuntu.com/ubuntu/ raring universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ raring multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ raring multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ raring-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ raring-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu raring-security main restricted
deb-src http://security.ubuntu.com/ubuntu raring-security main restricted
deb http://security.ubuntu.com/ubuntu raring-security universe
deb-src http://security.ubuntu.com/ubuntu raring-security universe
deb http://security.ubuntu.com/ubuntu raring-security multiverse
deb-src http://security.ubuntu.com/ubuntu raring-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu quantal partner
# deb-src http://archive.canonical.com/ubuntu quantal partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu raring main
deb-src http://extras.ubuntu.com/ubuntu raring main

cat /etc/apt/sources.list.d/*

# deb http://ppa.launchpad.net/bjori/php5/ubuntu raring main
# deb-src http://ppa.launchpad.net/bjori/php5/ubuntu raring main
# deb http://ppa.launchpad.net/bjori/php5/ubuntu raring main
# deb-src http://ppa.launchpad.net/bjori/php5/ubuntu raring main
# deb http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu raring main
# deb-src http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu raring main
deb http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu raring main
# deb-src http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu raring main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/chrome/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/chrome/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/chrome/deb/ stable main
# needed sources for php5.3:
deb http://kambing.ui.ac.id/ubuntu/ precise main restricted
deb-src http://kambing.ui.ac.id/ubuntu/ precise main restricted

deb http://kambing.ui.ac.id/ubuntu/ precise-updates main restricted
deb-src http://kambing.ui.ac.id/ubuntu/ precise-updates main restricted

deb http://kambing.ui.ac.id/ubuntu/ precise universe
deb-src http://kambing.ui.ac.id/ubuntu/ precise universe
deb http://kambing.ui.ac.id/ubuntu/ precise-updates universe
deb-src http://kambing.ui.ac.id/ubuntu/ precise-updates universe

deb http://kambing.ui.ac.id/ubuntu/ precise multiverse
deb-src http://kambing.ui.ac.id/ubuntu/ precise multiverse
deb http://kambing.ui.ac.id/ubuntu/ precise-updates multiverse
deb-src http://kambing.ui.ac.id/ubuntu/ precise-updates multiverse
deb-src http://kambing.ui.ac.id/ubuntu/ natty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

deb-src http://archive.canonical.com/ubuntu natty partner

deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main

deb http://kambing.ui.ac.id/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://kambing.ui.ac.id/ubuntu/ precise-backports main restricted universe multiverse


deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner


# needed sources for php5.3:
deb http://kambing.ui.ac.id/ubuntu/ precise main restricted
deb-src http://kambing.ui.ac.id/ubuntu/ precise main restricted

deb http://kambing.ui.ac.id/ubuntu/ precise-updates main restricted
deb-src http://kambing.ui.ac.id/ubuntu/ precise-updates main restricted

deb http://kambing.ui.ac.id/ubuntu/ precise universe
deb-src http://kambing.ui.ac.id/ubuntu/ precise universe
deb http://kambing.ui.ac.id/ubuntu/ precise-updates universe
deb-src http://kambing.ui.ac.id/ubuntu/ precise-updates universe

deb http://kambing.ui.ac.id/ubuntu/ precise multiverse
deb-src http://kambing.ui.ac.id/ubuntu/ precise multiverse
deb http://kambing.ui.ac.id/ubuntu/ precise-updates multiverse
deb-src http://kambing.ui.ac.id/ubuntu/ precise-updates multiverse
deb-src http://kambing.ui.ac.id/ubuntu/ natty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

deb-src http://archive.canonical.com/ubuntu natty partner

deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main

deb http://kambing.ui.ac.id/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://kambing.ui.ac.id/ubuntu/ precise-backports main restricted universe multiverse


deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner


# deb http://ppa.launchpad.net/webupd8team/java/ubuntu raring main # disabled on upgrade to raring
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu raring main # disabled on upgrade to raring
deb http://ppa.launchpad.net/webupd8team/java/ubuntu quantal main
deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu quantal main
# deb http://ppa.launchpad.net/webupd8team/java/ubuntu raring main # disabled on upgrade to raring
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu raring main # disabled on upgrade to raring
# deb http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu raring main
# deb-src http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu raring main
# deb http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu raring main
# deb-src http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu raring main

sudo dpkg --configure -a

dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-extra-3.8.0-35-generic; however:
  Package linux-image-extra-3.8.0-35-generic is not installed.

dpkg: error processing linux-image-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-image-generic (= 3.8.0.35.53); however:
  Package linux-image-generic is not configured yet.

dpkg: error processing linux-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic-pae:
 linux-generic-pae depends on linux-generic (= 3.8.0.35.53); however:
  Package linux-generic is not configured yet.

dpkg: error processing linux-generic-pae (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-generic
 linux-generic
 linux-generic-pae

Edit: I found that my sources.list have been messed up mainly due to the use of https://gist.github.com/awm086/6510924 to downgrade a version of php

share|improve this question
    
I have seen it and it did not help... –  Ali Mar 5 at 23:14
    
what when you tried to follow the answer? –  Alvar Mar 5 at 23:14
    
@Ali There are quite a few answers on that questions. Did you only try the first one? –  Seth Mar 5 at 23:15
    
Have you seen this? askubuntu.com/questions/195950/… –  Seth Mar 5 at 23:17
    
@Alvar I have followed the answere until i reached a deadend. I get to the point of sudo apt-get -f install and it errors out. Now, I am at the Getting help section. –  Ali Mar 5 at 23:19

1 Answer 1

up vote 4 down vote accepted

You don't have dependencies issues but simply file collisions due mixing diferent repositories precise, quantal and raring. I'm not even sure what your system is anymore, which you should check using lsb_release -sc or use quantal as the header of the sources.list file suggest. You should remove/comment all the repositories that are not your version of Ubuntu, update your package list (sudo apt-get clean && sudo apt-get update) and pray that sudo apt-get -f install doesn't throw more errors. Ah, you should also remove the linux-image-extra-3.8.0-35-generic package.

share|improve this answer
    
also it is raring. lsb_release -sc gives raring –  Ali Mar 6 at 0:01
    
@Ali I would give up that installation, and for the next time not mixing repositories as you did. –  Braiam Mar 6 at 0:14
    
Thanks, I am not sure how repositories were mixed. Also, every time I do sudo apt-get -f install i get The following extra packages will be installed: linux-image-extra-3.8.0-35-generic. Lastly, what do you mean by give up the installation? Start over? –  Ali Mar 6 at 0:17
    
Thank you, I fixed it. This started when I tried a specific type of php installation for phpbrew that gave me some dependencies problem when I executed apt-get build-dep php5.I tried to resolve them following other answers and made the problem worse. This along with possible existing problems on my system(mixed repos)led to the mess. I followed you advice and used quantal. In etc/apt/ I noticed sources.list.distUpgrade. so I did sudo cp sources.list.distUpgrade sources.list then sudo apt-get clean && sudo apt-get update and then sudo apt-get upgrade and everything is working fine now. –  Ali Mar 6 at 0:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.