Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
“Problem with MergeList” error when trying to do an update

I get the following message when running apt on this public hotel wifi:

$ sudo apt-get update
Ign http://archive.canonical.com natty InRelease
Ign http://security.ubuntu.com natty-security InRelease                        
Ign http://extras.ubuntu.com natty InRelease                                   
OK   http://archive.canonical.com natty Release.gpg                            
OK   http://security.ubuntu.com natty-security Release.gpg                 
OK   http://extras.ubuntu.com natty Release.gpg                            
Ign http://de.archive.ubuntu.com natty InRelease                           
Ign http://de.archive.ubuntu.com natty-updates InRelease                   
OK   http://archive.canonical.com natty Release                            
Ign http://de.archive.ubuntu.com natty-security InRelease                  
OK   http://extras.ubuntu.com natty Release                                
OK   http://security.ubuntu.com natty-security Release                     
OK   http://de.archive.ubuntu.com natty Release.gpg                        
OK   http://de.archive.ubuntu.com natty-updates Release.gpg               
OK   http://archive.canonical.com natty/partner i386 Packages             
Hole:1 http://de.archive.ubuntu.com natty-security Release.gpg [198 B]         
Ign http://archive.canonical.com natty/partner TranslationIndex                
OK   http://extras.ubuntu.com natty/main Sources                               
OK   http://extras.ubuntu.com natty/main i386 Packages                     
Ign http://extras.ubuntu.com natty/main TranslationIndex                       
OK   http://de.archive.ubuntu.com natty Release                                
OK   http://security.ubuntu.com natty-security/main i386 Packages          
OK   http://security.ubuntu.com natty-security/restricted i386 Packages        
OK   http://security.ubuntu.com natty-security/universe i386 Packages          
OK   http://security.ubuntu.com natty-security/multiverse i386 Packages        
Ign http://security.ubuntu.com natty-security/main TranslationIndex            
OK   http://de.archive.ubuntu.com natty-updates Release                        
Ign http://security.ubuntu.com natty-security/multiverse TranslationIndex      
Ign http://security.ubuntu.com natty-security/restricted TranslationIndex      
Ign http://security.ubuntu.com natty-security/universe TranslationIndex        
Hole:2 http://de.archive.ubuntu.com natty-security Release [23,2 kB]           
OK   http://de.archive.ubuntu.com natty/main Sources                           
OK   http://de.archive.ubuntu.com natty/restricted Sources                     
OK   http://de.archive.ubuntu.com natty/universe Sources                       
OK   http://de.archive.ubuntu.com natty/multiverse Sources                     
OK   http://de.archive.ubuntu.com natty/main i386 Packages                     
OK   http://de.archive.ubuntu.com natty/restricted i386 Packages               
OK   http://de.archive.ubuntu.com natty/universe i386 Packages                 
OK   http://de.archive.ubuntu.com natty/multiverse i386 Packages               
Ign http://de.archive.ubuntu.com natty/main TranslationIndex                   
Ign http://de.archive.ubuntu.com natty/multiverse TranslationIndex             
Ign http://de.archive.ubuntu.com natty/restricted TranslationIndex             
Ign http://de.archive.ubuntu.com natty/universe TranslationIndex               
OK   http://de.archive.ubuntu.com natty-updates/main Sources                   
OK   http://de.archive.ubuntu.com natty-updates/restricted Sources             
OK   http://de.archive.ubuntu.com natty-updates/universe Sources               
OK   http://de.archive.ubuntu.com natty-updates/multiverse Sources             
OK   http://de.archive.ubuntu.com natty-updates/main i386 Packages             
OK   http://de.archive.ubuntu.com natty-updates/restricted i386 Packages       
OK   http://de.archive.ubuntu.com natty-updates/universe i386 Packages         
Ign http://archive.canonical.com natty/partner Translation-de_DE               
OK   http://de.archive.ubuntu.com natty-updates/multiverse i386 Packages       
Ign http://extras.ubuntu.com natty/main Translation-de_DE                      
Ign http://de.archive.ubuntu.com natty-updates/main TranslationIndex           
Ign http://archive.canonical.com natty/partner Translation-de                  
Ign http://de.archive.ubuntu.com natty-updates/multiverse TranslationIndex     
Ign http://de.archive.ubuntu.com natty-updates/restricted TranslationIndex     
Ign http://de.archive.ubuntu.com natty-updates/universe TranslationIndex       
Ign http://extras.ubuntu.com natty/main Translation-de                         
OK   http://de.archive.ubuntu.com natty/main Translation-de                    
Ign http://archive.canonical.com natty/partner Translation-en                  
Ign http://extras.ubuntu.com natty/main Translation-en                         
Hole:3 http://de.archive.ubuntu.com natty-security/main Sources [5.941 B]  
Hole:4 http://de.archive.ubuntu.com natty-security/restricted Sources [14 B]
Hole:5 http://de.archive.ubuntu.com natty-security/universe Sources [2.145 B]
Hole:6 http://de.archive.ubuntu.com natty-security/multiverse Sources [14 B]
Ign http://security.ubuntu.com natty-security/main Translation-de_DE
Ign http://security.ubuntu.com natty-security/main Translation-de
OK   http://de.archive.ubuntu.com natty/multiverse Translation-de        
OK   http://de.archive.ubuntu.com natty/restricted Translation-de        
Ign http://security.ubuntu.com natty-security/main Translation-en        
Ign http://security.ubuntu.com natty-security/multiverse Translation-de_DE
Ign http://security.ubuntu.com natty-security/multiverse Translation-de
Ign http://security.ubuntu.com natty-security/multiverse Translation-en
Ign http://security.ubuntu.com natty-security/restricted Translation-de_DE
Ign http://security.ubuntu.com natty-security/restricted Translation-de
OK   http://de.archive.ubuntu.com natty/universe Translation-de
Ign http://security.ubuntu.com natty-security/restricted Translation-en
Ign http://security.ubuntu.com natty-security/universe Translation-de_DE
Ign http://security.ubuntu.com natty-security/universe Translation-de
Ign http://security.ubuntu.com natty-security/universe Translation-en
Ign http://de.archive.ubuntu.com natty/main Translation-de_DE
Ign http://de.archive.ubuntu.com natty/main Translation-en
Ign http://de.archive.ubuntu.com natty/multiverse Translation-de_DE
Ign http://de.archive.ubuntu.com natty/multiverse Translation-en
Ign http://de.archive.ubuntu.com natty/restricted Translation-de_DE
Ign http://de.archive.ubuntu.com natty/restricted Translation-en
Ign http://de.archive.ubuntu.com natty/universe Translation-de_DE
Ign http://de.archive.ubuntu.com natty/universe Translation-en
Ign http://de.archive.ubuntu.com natty-updates/main Translation-de_DE
Ign http://de.archive.ubuntu.com natty-updates/main Translation-de
Ign http://de.archive.ubuntu.com natty-updates/main Translation-en
Ign http://de.archive.ubuntu.com natty-updates/multiverse Translation-de_DE
Ign http://de.archive.ubuntu.com natty-updates/multiverse Translation-de
Ign http://de.archive.ubuntu.com natty-updates/multiverse Translation-en
Ign http://de.archive.ubuntu.com natty-updates/restricted Translation-de_DE
Ign http://de.archive.ubuntu.com natty-updates/restricted Translation-de
Ign http://de.archive.ubuntu.com natty-updates/restricted Translation-en
Ign http://de.archive.ubuntu.com natty-updates/universe Translation-de_DE
Ign http://de.archive.ubuntu.com natty-updates/universe Translation-de
Ign http://de.archive.ubuntu.com natty-updates/universe Translation-en
Es wurden 31,5 kB in 4 s geholt (7.340 B/s)
Paketlisten werden gelesen... Fehler!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/de.archive.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages
E: Die Paketliste oder die Statusdatei konnte nicht eingelesen oder geöffnet werden.

Package list are read ... Error! E: Encountered ... E: The package file or the status file could not be read or opened

How can I fix that?

share|improve this question

marked as duplicate by Jorge Castro, Marco Ceppi Jul 14 '11 at 3:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 2 down vote accepted

Just delete the lists that apt has cached with a rm -rf /var/lib/apt/lists/* and it will reload them from scratch.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.