Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm unsure how to get around the following, help is appreciated!

$ sudo apt-get autoremove
[sudo] password for heath: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

$ sudo dpkg--configure -a

$ sudo apt-get install kubuntu-desktop

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kubuntu-desktop :

               Depends: kde-workspace but it is not going to be installed
               Depends: okular but it is not going to be installed
               Depends: plasma-desktop but it is not going to be installed
               Depends: plasma-netbook but it is not going to be installed
               Depends: software-properties-kde but it is not going to be installed
               Recommends: akregator but it is not going to be installed
               Recommends: apport-kde but it is not going to be installed
               Recommends: apturl-kde but it is not going to be installed
               Recommends: jockey-kde but it is not going to be installed
               Recommends: kaddressbook but it is not going to be installed
               Recommends: kate but it is not going to be installed
               Recommends: kde-config-touchpad but it is not going to be installed
               Recommends: kdepim-kresources but it is not going to be installed
               Recommends: kexi but it is not going to be installed
               Recommends: kmail but it is not going to be installed
               Recommends: knotes but it is not going to be installed
               Recommends: kontact but it is not going to be installed
               Recommends: korganizer but it is not going to be installed
               Recommends: krita but it is not going to be installed
               Recommends: kubuntu-firefox-installer but it is not going to be installed
               Recommends: kubuntu-notification-helper but it is not going to be installed
               Recommends: libreoffice-kde but it is not going to be installed
               Recommends: muon but it is not going to be installed
               Recommends: muon-discover but it is not going to be installed
               Recommends: muon-notifier but it is not going to be installed
               Recommends: plasma-widget-facebook but it is not going to be installed
               Recommends: plasma-widgets-addons but it is not going to be installed
               Recommends: usb-creator-kde but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Here's the update after trying the advice in the page which was linked to (when someone marked this as a duplicate):

sudo apt-get clean && sudo apt-get autoclean && sudo apt-get -f install && sudo dpkg --configure -a && sudo apt-get -f install
[sudo] password for heath: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[hsenv](d)➜  ~  sudo apt-get -u dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[hsenv](d)➜  ~  sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[hsenv](d)➜  ~  mkdir ppa-purge && cd ppa-purge && wget //mirror.pnl.gov/ubuntu/pool/universe/p/ppa-purge/ppa-purge_0.2.8+bzr56_all.deb && wget //mirror.pnl.gov/ubuntu//pool/main/a/aptitude/aptitude_0.6.6-1ubuntu1_i386.deb && sudo dpkg -i ./*.deb
--2014-03-06 09:56:34--  //mirror.pnl.gov/ubuntu/pool/universe/p/ppa-purge/ppa-purge_0.2.8+bzr56_all.deb
Resolving mirror.pnl.gov (mirror.pnl.gov)... 192.101.102.2
Connecting to mirror.pnl.gov (mirror.pnl.gov)|192.101.102.2|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4360 (4.3K) [application/x-troff-man]
Saving to: ‘ppa-purge_0.2.8+bzr56_all.deb’

100%[================================================================================================================================================>] 4,360       --.-K/s   in 0s      

2014-03-06 09:56:34 (14.6 MB/s) - ‘ppa-purge_0.2.8+bzr56_all.deb’ saved [4360/4360]

--2014-03-06 09:56:34--  //mirror.pnl.gov/ubuntu//pool/main/a/aptitude/aptitude_0.6.6-1ubuntu1_i386.deb
Resolving mirror.pnl.gov (mirror.pnl.gov)... 192.101.102.2
Connecting to mirror.pnl.gov (mirror.pnl.gov)|192.101.102.2|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2352134 (2.2M) [application/x-troff-man]
Saving to: ‘aptitude_0.6.6-1ubuntu1_i386.deb’

100%[================================================================================================================================================>] 2,352,134    782KB/s   in 2.9s   

2014-03-06 09:56:38 (782 KB/s) - ‘aptitude_0.6.6-1ubuntu1_i386.deb’ saved [2352134/2352134]

Selecting previously unselected package aptitude.
(Reading database ... 230150 files and directories currently installed.)
Unpacking aptitude (from .../aptitude_0.6.6-1ubuntu1_i386.deb) ...
Selecting previously unselected package ppa-purge.
Unpacking ppa-purge (from .../ppa-purge_0.2.8+bzr56_all.deb) ...
dpkg: dependency problems prevent configuration of aptitude:
 aptitude depends on libapt-pkg4.12 (>= 0.8.16~exp12ubuntu6).
 aptitude depends on libboost-iostreams1.46.1 (>= 1.46.1-1).
 aptitude depends on libc6 (>= 2.4).
 aptitude depends on libcwidget3.
 aptitude depends on libept1.4.12.
 aptitude depends on libgcc1 (>= 1:4.1.1).
 aptitude depends on libncursesw5 (>= 5.6+20070908).
 aptitude depends on libsigc++-2.0-0c2a (>= 2.0.2).
 aptitude depends on libsqlite3-0 (>= 3.6.5).
 aptitude depends on libstdc++6 (>= 4.6).
 aptitude depends on libtinfo5.
 aptitude depends on libxapian22.

dpkg: error processing aptitude (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ppa-purge:
 ppa-purge depends on aptitude.

dpkg: error processing ppa-purge (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 aptitude
 ppa-purge
share|improve this question
    
None of those solutions solved the problem, see the update on the question. –  Heath Mar 6 at 15:57
    
Edit your question and add the output of sudo apt-get check, apt-cache policy kubuntu-desktop kde-workspace and sudo apt-get update. –  Braiam Mar 6 at 23:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.