Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some reason I got a really bad wifi reception in my bedroom under ubuntu. Under windows everything is fine. My tablet and my phone don't have problems either. By bad reception I mean that I have to put my laptop in specific area to have a connection and I often need to move because I lost the connection...

Can't figure out why.

~# lshw -C net
  *-network
       description: Wireless interface
       product: Centrino Advanced-N 6235
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: wlan0
       version: 24
       serial: c4:85:08:b1:24:84
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.11.0-17-generic firmware=18.168.6.1 ip=192.168.2.12 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:48 memory:d2600000-d2601fff

# iwconfig 
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"hotixiaspot"  
          Mode:Managed  Frequency:2.452 GHz  Access Point: EC:1A:59:04:70:BC   
          Bit Rate=57.8 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=44/70  Signal level=-66 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:23426  Invalid misc:1524   Missed beacon:0
share|improve this question
    
Please give some examples on what the signal level is in dBm at identical spots with Ubuntu/Windows –  bigbadonk420 Mar 5 at 14:46

2 Answers 2

You may find, as I did with a very similar iwlwifi device, that signal strength and stability are greatly improved if you set the router to restrict channel width to 20 MHz only and not 20/40 MHz. enter image description here

share|improve this answer
    
I'll try that. thanks –  tibo Mar 7 at 0:37

This may have its causes in the drivers. You may have a look at this answer to a similar question on SE Unix&Linux.

If available, you should install a manufacturer driver for your WiFi card. From your lshw stuff I assume Ubuntu doesn't exactly know what the device is, so it uses a (more or less) working generic driver.

Some companies supply Linux drivers (like Realtek does for my card), some don't. So you could try your luck this way.

Another possibility would be to disable ACPI power management for your Wifi card. Have a look at this AU question. Before doing this, check whether your card is managed by ACPI at all: iwconfig gives you information about wireless devices. There's a line saying Power Management:.... If it says On, try the method in the link, if not, it won't have an effect.

share|improve this answer
    
As you can see in my lshw Ubuntu actually knows excatly which card I am using and is using the official driver of Intel, the latest one. In my iwconfig you can also see that the power management is off. Thanks for your help anyway. –  tibo Mar 7 at 0:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.