Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Yes! I want to get rid of the guest account on Ubuntu. How do I do this??

I do not want this account but neither I find it in /etc/passwd and /etc/group nor within the users by navigating to system Settings -> user accounts...

share|improve this question

marked as duplicate by Ask, Mitch Mar 5 at 12:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

  1. Open /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf with root rights.
  2. Append the line allow-guest=false
  3. Reboot.
share|improve this answer

I don't know if you can remove the account, but you can disable it : it won't be an option at login.

  • Edit /etc/lightdm/lightdm.conf

    sudo nano /etc/lightdm/lightdm.conf
    
  • Add the following line at the end :

    allow-guest = false
    
  • Save CTRL + O

  • Quit the text-editor CTRL + X


Or in one command-line :

echo "allow-guest = false" | sudo tee -a /etc/lightdm/lightdm.conf
share|improve this answer
    
This did work well on earlier versions, but does not work on 13.10. –  Klaus Warzecha Mar 5 at 12:25
    
Well, I'm currently using this and it works. And I'm on 13.10. –  MrVaykadji Mar 5 at 12:27
    
So you created the file? Well then, because there's no /etc/lightdm/lightdm.conf on 13.10 by default. –  Klaus Warzecha Mar 5 at 12:31
    
uuuh, yeah there is one by default^^ –  MrVaykadji Mar 5 at 12:32
1  
Very strange ^^ From 13.10, all options should be in the "numbered files" in /etc/lightdm/lightdm.conf.d/. But let's not argue about this, as long as everything works :) –  Klaus Warzecha Mar 5 at 12:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.