Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have put my app (implemented a website with the help of angularjs) on amazon EC2 and have installed nginx and thin on it

I am having issues with angularjs with respect to performance.

So I decide to install Pagespeed with recommendation of my seniors.

I am following the steps from here and here.

However I am stuck with

./configure --add-module=$HOME/ngx_pagespeed-release-

I don't know the meaning of ./configure. I don't have such a file or directory in nginx path.

I had installed nginx before so I skipped the part where we have to install nginx server. Also I have installed the pagespeed module in root directory and nginx on /etc/nginx.

Is this why it is giving me issues and how do I solve this. Do I need to reinstall Nginx?

Please help me with this.

share|improve this question

There is no "pagespeed module", did you mean the source code? nginx does not have a notion of dynamically loadable modules. Every module you enable is added to the main executable (/usr/sbin/nginx).

configure is a script in the source distribution of nginx, you won't find it anywhere on your filesystem unless you downloaded it. Remove your existing nginx binary and proceed with the mentioned instructions. Note that you are then fully responsible for any (security) updates.

share|improve this answer
Thanks for the help..I have written a lot of rules for nginx.conf ..Hence will cause problems if i have to delete it.Also is there any other kind of tool which i can use for similar similar to pagespeed.. – Workforce Mar 6 '14 at 9:45
@Workforce It sounds you do not have a backup of your configuration. You should fix that first. Once you install the newer version of nginx, you can add the new configuration as needed. If you remove nginx without --purge option, then the configuration is also retained. Profile where your performance issue resides (server, client, network, ...) and try to fix the real problem instead of random guessing. – Lekensteyn Mar 6 '14 at 14:28
Thanks i will try it out – Workforce Mar 6 '14 at 16:09

If you want nginx-pagespeed support use following repository

add-apt-repository -y ppa:rtcamp/nginx
apt-get update && apt-get install nginx-custom


share|improve this answer
This worked perfectly. Thank you. – Tim Perry Mar 1 at 19:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.