Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My problem is that whenever I try downloading a big file (100MB or more), it always gets completed but file is corrupted. I have been observing this when downloading Eclipse IDE. I tried many Eclipse versions, Scala IDE, but all result in the same error.

Is there something wrong with my Internet connection or my Hard Drive?

How to diagnose and fix this problem?

*Update *

i tried using another computer to download the same file on the same internet connection. the file download is successful. so it means something wrong in my harddisk only. i checked the Disk 'palimpsest' report and does show many "read errors" and many "Seek Errors" , many "hardware ECC recovered" . But the "Uncorrectable Sector Count" is 0. Does that mean my disk is a problem but it is a recoverable error? what can be done to recover from these errors?

Update 2

i tried attaching my phone as a USB device and downloaded the file in it. the file was downloaded using wget -c command. The same error occured, i.e. extracting the .tar.gz file failed as there was a CRC error that means Harddisk is OK, and internet connection is OK (see Update 1) , but there is something wrong in the OS? many times i am not even able to apply all updates as the updates also fail for the same reason "Hash Sum Mismatch" plz help!!

share|improve this question
    
Sometimes it happens due to internet connection. Better use any download manager like flareGetto download big files. –  Guru Mar 4 at 20:38
    
nope, i just now tried with flareGet also, but same kind of error. file cannot be opened. this is the file i am trying to download downloads.typesafe.com/scalaide-pack/3.0.2.vfinal-210-20131028/… –  weima Mar 4 at 21:03
    
i get the error:tar: Skipping to next header gzip: stdin: invalid compressed data--crc error gzip: stdin: invalid compressed data--length error tar: Child returned status 1 tar: Error is not recoverable: exiting now –  weima Mar 4 at 21:04
    
anyone? help please –  weima Mar 5 at 7:05
1  
What version of ubuntu are you using? Are you using a wired connection or a wireless connection? Please edit your question with what router you are using. –  i08in Mar 13 at 11:59
show 9 more comments

5 Answers 5

up vote 0 down vote accepted
+50

I asked him to check md5sum of the downloaded 100 MB file. This comment clearly shows that his file was corrupted or may be chance of bit loss while downloading that file using a specific download manager(flareget).

So try to download that 100 MB file using different download manager.So see this question for the available download managers in Ubuntu which allows you to pause,resume while downloading.

share|improve this answer
    
gzip: stdin: invalid compressed data--crc error tar: Child returned status 1 tar: Error is not recoverable: exiting now –  weima Mar 12 at 19:01
    
did you login into root account? –  Avinash Raj Mar 12 at 19:02
    
there is enough space in the partition /dev/sda4 611G 225G 355G 39% /data –  weima Mar 12 at 19:02
    
try tar -xf /path/filename.tar.gz command. –  Avinash Raj Mar 12 at 19:03
1  
hi @AvinashRaj i got the sha1sum from the site. it is 3b22333939c745257847a5173f288571b7f8f432 but after downloading today i get 76afc0bf2c2cb2c15b558032e24d0381c487a0ae i dont know what is wrong –  weima Mar 13 at 15:33
show 9 more comments

Try to download the large file from terminal using wget

Example: $ wget http://www.openss7.org/repos/tarballs/strx25-0.9.2.1.tar.bz2

This will show you the progress and whether it got interrupted.

If got interrupted; you may resume the download again by adding -c switch as in the following

Example : $ wget -c http://www.openss7.org/repos/tarballs/strx25-0.9.2.1.tar.bz2

Source: http://www.thegeekstuff.com/2009/09/the-ultimate-wget-download-guide-with-15-awesome-examples/

share|improve this answer
add comment

It's a flareget bug

I have been using flareget for months now.It was working properly for some time, but nowadays, after an update or something, flareget corrupts every file.For now, using mozilla or any other browser is your best choice.

The invalid commpressed data error should not appear when you try downloading via browser.If it still does, use wget to download the file using command

wget -c <link>

You can use the following command to decompress the file

gzip -d /path/to/file

If error occurs, use force option

gzip -df /path/to/file

For extra guarranty, you may first want to check the integrity of file using

gzip -t /path/to/file
share|improve this answer
add comment

You can try pointing the download to another external static memory device like a USB flash drive or maybe even your cellphones SD card. If the download completely loads into the external memory device, then you may want to evaluate your local hardware for inconsistencies.

share|improve this answer
add comment

What are the facts so far on this issue?

  1. This happens only on big files (You tested this on other files?)
  2. The CRC check fails
  3. Download resumes are not helping either.

I am wondering if you don't have some cache manager or proxy or policy that writes to your open download...

You can try to spot differences using if you can get your hand on the original:

hexdump -C  scala-SDK-3.0.2-vfinal-2.10-linux.gtk.x86_64.tar.gz | head -n20

Have you tried doing the download via an independent internet connection?

Good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.