Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I must have done something especially stupid, but I observe the following behavior:

  1. When I start gdm, I see the "Warning: unable to load /etc/gdm/custom.conf: file not found" message.
  2. My GDM session list contains only to basic sessions (an empty one and an xterm one) available in /usr/share/xsessions.

My question is: what exactly have I broken and how do I bring Unity xsession config back? If it's as simple as copying a file into /usr/share/xsessions, I'd be grateful if someone posted a working unity config here, since when I launch Unity from xterm with simply unity, none of my settings are applied. Thanks!

share|improve this question
add comment

1 Answer

up vote 6 down vote accepted

Try reinstalling the gnome-session package:

sudo apt-get install --reinstall gnome-session
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.