Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have pre-installed windows 8.1 and I installed ubuntu 13.10.

This is what I see -

enter image description here

Boot Mode - [Legacy] 
Boot Priority - [UEFI]

Issue here is when I restart my computer it doesn't ask for windows or ubuntu selection. And start the windows 8.1.

When I change the configuration to

Boot Mode - [Legacy]
Boot Priority - [Legacy]

Purple screen comes up to choose ubuntu or windows. When I choose ubuntu it works perfectly fine.

After login to ubuntu.

krunal@krunal-Lenovo-IdeaPad-U530-Touch:~$ [ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD"
Legacy boot on HDD
krunal@krunal-Lenovo-IdeaPad-U530-Touch:~$ 
krunal@krunal-Lenovo-IdeaPad-U530-Touch:~$ sudo blkid
/dev/sdb1: LABEL="WINRE_DRV" UUID="309C4CD59C4C96EE" TYPE="ntfs" 
/dev/sdb2: LABEL="SYSTEM_DRV" UUID="684F-4292" TYPE="vfat" 
/dev/sdb3: LABEL="LRS_ESP" UUID="3854-3E3C" TYPE="vfat" 
/dev/sdb5: LABEL="Windows8_OS" UUID="AAD0579BD0576C97" TYPE="ntfs" 
/dev/sdb6: LABEL="LENOVO" UUID="8654250A5424FE95" TYPE="ntfs" 
/dev/sdb7: LABEL="PBR_DRV" UUID="5E625CB7625C961D" TYPE="ntfs" 
/dev/sdb9: UUID="9e762872-601b-4518-91d2-7826bc488b61" TYPE="ext4" 
/dev/sdb10: UUID="3562b3f6-6f08-45c7-b16d-41a98712a1a6" TYPE="swap" 

EDIT this is what I see in boot manager now. Is this correct ?

enter image description here

But when I click windows it doesn't understand and show messages and stops there. After that I have to restart my computer by pressing power button.

share|improve this question

marked as duplicate by Luis Alvarado Mar 4 at 16:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
did you turn off secure boot and fast startup?And also what error messages are shown while you boot Windows? –  Avinash Raj Mar 4 at 15:43
    
Yes I have turned off both the settings. –  krunal shah Mar 4 at 15:50
    
Boot into Ubuntu and post the output of [ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD" command. –  Avinash Raj Mar 4 at 15:56
    
I have updated my question. Getting "Legacy boot on hDD" –  krunal shah Mar 4 at 16:05
    
Run boot-repair and post it's log in pastebin.com and provide the uploaded link here. –  Avinash Raj Mar 4 at 16:09
show 8 more comments

2 Answers 2

You installed Ubuntu in Legacy mode.But you installed Windows in UEFI Mode.So you have to convert Ubuntu into EFI mode.

So this will help you.

share|improve this answer
    
The boot of your PC is in Legacy mode. You may want to retry after changing it to EFI mode. How can I change it EFI ? –  krunal shah Mar 4 at 16:46
    
Please do not forget to make your BIOS boot on sdb2/EFI/ubuntu/shimx64.efi file! How can I make sure my BIOS boot on this ? –  krunal shah Mar 4 at 16:47
    
change boot mode and boot priority to UEFI in bios and then follow the link above. –  Avinash Raj Mar 4 at 16:48
    
already followed the link above.. Now I want to change the bios to UEFI. But don't know How can I get there to change it? –  krunal shah Mar 4 at 16:49
    
first change the boot mode,pripority to uefi in bios and save the changes.Then boot from Ubuntu live disk, install boot-repair and select the efi partition in advance option and so on. –  Avinash Raj Mar 4 at 16:52
show 6 more comments

Have you tried using EasyBCD? Download/install in Windows, open and choose Type: GRUB2 in the "Add new entry" section

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.