Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a laptop with a Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak].

Here is the adapter information:

stan@pho:~/Downloads$ lspci | grep -i net
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]
04:00.0 Ethernet controller: Marvell Technology Group Ltd. Yukon Optima 88E8059 [PCIe Gigabit Ethernet Controller with AVB] (rev 11)

The adapter gets connected, an it gets immediately disconnected. And that is repeated infinite times.

The output of dmesg | egrep 'wlan0|iwl' show the following lines multiple times:

[ 1752.722768] wlan0: authenticate with 20:aa:4b:cb:40:94
[ 1752.743331] wlan0: send auth to 20:aa:4b:cb:40:94 (try 1/3)
[ 1752.750735] wlan0: authenticated
[ 1752.754666] wlan0: associate with 20:aa:4b:cb:40:94 (try 1/3)
[ 1752.758641] wlan0: RX AssocResp from 20:aa:4b:cb:40:94 (capab=0x411 status=0 aid=2)
[ 1752.763976] wlan0: associated
[ 1801.420240] wlan0: deauthenticating from 20:aa:4b:cb:40:94 by local choice (reason=3)

It seems the most common solution is to disable the N mode from the wireless card, so I tried this:

sudo modprobe -r iwldvm
sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=1

But it is still not working.


I can confirm that the issue is related to the Wireless N mode. If I go to the admin page of my router and configure it to only use Wireless B/G mode, then my computer can keep a connection with the router.

enter image description here

So, I guess there is something wrong with the commands I typed to disable N mode in the wires adapter of my computer.

Any idea what am I missing?

share|improve this question
up vote 0 down vote accepted

This command will turn N speed off for your device permanently but not in your router:

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwldvm
sudo modprobe -rfv iwlwifi
sudo modprobe -v iwlwifi

The commands you ran in your question to disable N speed are only temporary they are lost when you reboot.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.