Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Gallium 0.4 on AMD RV730

Intel® Core™2 Duo CPU P7350 @ 2.00GHz × 2

Advanced Micro Devices, Inc. [AMD/ATI] RV730/M96 [Mobility Radeon HD 4650/5165]

I downloaded the AMD Catalyst™ 13.1 Proprietary Linux x86 Display Driver

i unpacked it and then made these

XXX@XXX:~/Downloads$ sudo sh amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run --buildpkg Ubuntu/saucy
Created directory fglrx-install.lW2suh
Verifying archive integrity... All good.
Uncompressing AMD Catalyst(TM) Proprietary Driver-8.97.100.7....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
=====================================================================
AMD Catalyst(TM) Proprietary Driver Installer/Packager 
=====================================================================
Generating package: Ubuntu/saucy
Package /XXX/XXX/XXX/fglrx_8.970-0ubuntu1_amd64.deb has been successfully generated
Package /XXX/XXX/XXX/fglrx-dev_8.970-0ubuntu1_amd64.deb has been successfully generated
Package /XXX/XXX/XXX/fglrx-amdcccle_8.970-0ubuntu1_amd64.deb has been successfully generated
Removing temporary directory: fglrx-install.lW2suh

I get an error when I install the package

XXX@XXX:~/Downloads$ sudo dpkg -i fglrx*.deb
Selecting previously unselected package fglrx.
(Reading database ... 194458 files and directories currently installed.)
Unpacking fglrx (from fglrx_8.970-0ubuntu1_amd64.deb) ...
Selecting previously unselected package fglrx-amdcccle.
Unpacking fglrx-amdcccle (from fglrx-amdcccle_8.970-0ubuntu1_amd64.deb) ...
Selecting previously unselected package fglrx-dev.
Unpacking fglrx-dev (from fglrx-dev_8.970-0ubuntu1_amd64.deb) ...
Setting up fglrx (2:8.970-0ubuntu1) ...
update-alternatives: using /usr/lib/fglrx/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode
update-alternatives: warning: skip creation of /etc/OpenCL/vendors/amdocl32.icd because associated file /usr/lib/fglrx/etc/OpenCL/vendors/amdocl32.icd (of link group x86_64-linux-gnu_gl_conf) doesn't exist
update-alternatives: using /usr/lib/fglrx/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode
update-initramfs: deferring update (trigger activated)
Loading new fglrx-8.970 DKMS files...
First Installation: checking all kernels...
Building only for 3.11.0-17-generic
Building for architecture x86_64
Building initial module for 3.11.0-17-generic
Error! Bad return status for module build on kernel: 3.11.0-17-generic (x86_64)
Consult /var/lib/dkms/fglrx/8.970/build/make.log for more information.
update-initramfs: deferring update (trigger activated)
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf-2.index...
Setting up fglrx-amdcccle (2:8.970-0ubuntu1) ...
Setting up fglrx-dev (2:8.970-0ubuntu1) ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.11.0-17-generic
Processing triggers for libc-bin ...

make.log contains

DKMS make.log for fglrx-8.970 for kernel 3.11.0-17-generic (x86_64)
Mon Mar  3 19:49:08 CST 2014
AMD kernel module generator version 2.1
kernel includes at /lib/modules/3.11.0-17-generic/build/include not found or incomplete
file: /lib/modules/3.11.0-17-generic/build/include/linux/version.h

I'm following this guide: BinaryDriverHowto/AMD and I'm stuck

I am completely at a loss here. I'd really appreciate any help.

share|improve this question

1 Answer 1

For me it works just fine when i install these packages:

sudo apt-get install fglrx fglrx-pxpress

This installs the AMD Catalyst Control Center and i can use my AMD Radeon HD 7600M GPU

share|improve this answer
    
This doesn't work because OP asks for Legacy version of the driver. The package provided by Ubuntu only works for newer cards (including your HD 7600M). –  syockit Apr 17 at 16:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.