Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have followed the guide https://help.ubuntu.com/community/AsusZenbookPrime here and I am having multiple issues with my touchpad.

1) The sensitivity is far too high even when on the lowest setting in the settings option. Is there a commandline way to reduce it further?

2) The area of the touchpad that is registered as a right-click is only at the very bottom of the touchpad and so most of my right-clicks are registered as left-clicks. How can I make the right-click area be taller?

I have an Elantech touchpad. I set up the clickpad.sh as described, removing the inverse scrolling because I am not a fan of that:

#!/bin/bash 
gsettings set org.gnome.settings-daemon.peripherals.touchpad disable-while-typing false  
xinput set-prop "ETPS/2 Elantech Touchpad" "Synaptics ClickPad" 1 
xinput set-prop "ETPS/2 Elantech Touchpad" "Synaptics Soft Button Areas" 1956 0 1737 0 1304 1955 1737 0 
syndaemon -i 1.7 -d -t -K
xinput set-prop "ETPS/2 Elantech Touchpad" "Synaptics Scrolling Distance" 35, 35 # scroll more responsive
xinput set-prop "ETPS/2 Elantech Touchpad" "Synaptics Finger" 1, 15, 50 # ups click sensitivity, values '1, 15, 255' disable trackstick emulation
xinput set-prop "ETPS/2 Elantech Touchpad" "Synaptics Tap FastTap" 1 # faster taps
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.