Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to 11.04, and now most UI elements are gray and crappy looking (see screenshot).

When I first log in, the panel looks black (as Ambiance theme is supposed to look), but then after a second it turns gray and crappy-looking. Title bars of windows seem to be fine, but everything else seems messed up.

I've tried changing my theme in the "appearance" settings and it doesn't do anything besides change the title bars, and in 11.04 I can't seem to find any other settings related to this.

How can I fix this to look like it's supposed to look (default 11.04 theme)? Crappy UI widgets

share|improve this question
1  
    
@Uri Herrera: Thanks, that didn't fix it for me, but I did find something which seems to work in the Ubuntu bug that was linked from that question. –  TM. May 15 '11 at 21:34

1 Answer 1

up vote 3 down vote accepted

Using the answer to the question @Uri Herrera linked in his comment, I couldn't fix the issue.

However, one of the answers did point to a bug that tracks this issue, and I found a comment on the bug that solved it for me.

Here are the key bits:

First, create a bash script (I named it /etc/xdg/autostart/gnomesettingsdaemonfix.sh)

#!/bin/bash

pid=$(pgrep gnome-settings-)

while [ -n "$pid" ];
do
  pid=$(pgrep gnome-settings-)
  sleep 0
done

exit 0

Make sure it is executable (run chmod +x).

Then edit /etc/xdg/autostart/gnome-settings-daemon.desktop

Change the Exec line to:

Exec=bash -c 'bash /etc/xdg/autostart/gnomesettingsdaemonfix.sh; /usr/lib/gnome-settings-daemon/gnome-settings-daemon

That seems to have fixed it so far for me.

share|improve this answer
    
Can you put this answer in the original question? That way we have all the answers in one place. –  Jorge Castro May 15 '11 at 21:43
    
@Jorge Castro I can if you want, but I'm not sure if it's exactly the same problem... I don't have a core i7 or an SSD (as is mentioned in the other issue), and I also never had this problem on 10.10, only after upgrading to 11.04. –  TM. May 15 '11 at 21:46
    
It seems to be happening regardless of exact hardware and/or version, still if you got it off the bug report we could just have them all in one place. (I see this question come up a bunch of times) –  Jorge Castro May 15 '11 at 21:47
    
@Jorge Castro I made a copy over there as well. –  TM. May 15 '11 at 21:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.