Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Running vers. 13.10. Over a WiFi connection to a home ADSL router, DHCP. All working fine for 1 week after new Ubuntu installation. Try connecting to the internet, being told pages not available. WiFi access and other connected devices (this Android tablet for example) are fine. Checked ufw firewall (disabled) and tried pinging a few ip addresses without any joy. Subsequently, logged on the ubuntu laptop using the guest account,fired up Firefox and connected and was able to surf happily....for about 5 mins then same thing.Now unable to connect using either my account (with chrome) or the guest account with Firefox. All other household devices using the same internet connection are all fine. cat /etc/resolv.conf shows: # Dynamic resolv.conf ( 5 ) file for glibc resolver( 3 ) generated by resolvconf(8)....# DO NOT EDIT etc...nameserver search

share|improve this question
try ifconfig and make sure that you have a correct IP address If your "IP" and "gateway" are OK then try 'ping' – Ahmed Daif Mar 3 '14 at 11:37
Thanks Ahmed. ifconfig shows nothing on eth0, eth1 shows an ip of, a Bcast of and a subnet mask of There's another if called lo (whatever that is) with an address of and a mask of and it says UP LOOPBACK RUNNING MTU:65536 Metric:1 no errors shown. Ping says destination host unreachable. Any ideas. Thank you. – Eliot Mar 3 '14 at 12:31
Clearly Im no expert with Ubuntu, but why when I do an ifconfig look up do I not see any default gateway like I do on a Windows device, or even my android tablet. Gateway and DHCP server is and there are entries too for DNS servers but not on my Ubuntu laptop. PLEASE HELP...IM ABSOLUTELY DESPERATE. Thanks in advance. – Eliot Mar 3 '14 at 13:24
try route -n; if your gatway is not listed try sudo route add default gw or simply your router IP then sudo /etc/init.d/networking restartto apply the changes – Ahmed Daif Mar 3 '14 at 13:46
Hi Ahmed, OK, route -n shows the correct gateway address: Also, through Chrome I tried to connect to one of Google's ip addresses such as and I still cant connect, so that must mean that its not a DNS problem, yes? My new laptop running Ubuntu has become an expensive paperweight - very disapointed with what I'd hoped would be the start of a Microsoft free life :-( – Eliot Mar 3 '14 at 14:00

To be sure is dns problem type host if you get no answer with ip address try host If you got answer with ip address, you probably have no configured DNS parameters.

You can use nm-tool to see DNS servers

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.