Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm booting from a USB drive and selected the option Try Ubuntu (Ubuntu 13.10). Once it starts, it is showing only 2 partitions, the one where windows is installed and the other as unlabeled (this partition is shown as empty). I have windows installed in C:, D: and F: drives contain my data which are not being shown. I tried the command :

sudo fdisk -l 

and got the following message:

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xe0000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63      257039      128488+  de  Dell Utility
Partition 1 does not start on physical sector boundary.
/dev/sda2          257040      262143        2552   42  SFS
/dev/sda3   *      262144    20979711    10358784   42  SFS
/dev/sda4        20979712   276979711   128000000   42  SFS

Disk /dev/sdb: 16.1 GB, 16131293184 bytes
255 heads, 63 sectors/track, 1961 cylinders, total 31506432 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *       51248    31506430    15727591+   c  W95 FAT32 (LBA)
ubuntu@ubuntu:~$ 

I have a hard disk of 320 gb capacity, which is shown in this message, but why aren't the other drives( D: and F: ) being displayed?

share|improve this question
    
But sudo fdisk -l command displays all the 4 partitions.You can also look this on gparted partition editor. –  Avinash Raj Mar 3 at 8:14
    
I understood that all 4 partitions are being displayed in this message. I'm asking what can I do about it, how can I access data in those drives? –  codeln Mar 3 at 8:18

1 Answer 1

All the partitions in sda (first hard disk) are SFS (Windows 7 dynamic disks) and they are not supported by Ubuntu (they are encrypted by Windows).

You can convert then to notmal NTFS partitions if you want to use them both in Ubuntu and Windows. Check this question for more information.

share|improve this answer
    
I followed the post and it lead to this page: sevenforums.com/tutorials/… But when I'm trying to convert dynamic disk to basic disk as mentioned there, it is giving an error stating that it cannot be done. I'm not able to boot into windows so I tried this from a bootable usb. Please help –  codeln Mar 3 at 10:39
    
Ubuntu doesn't understand dynamic disks. You can't repair them from Ubuntu, you will need to use Windows tools. You can try asking for help in a Windows forum, people there could probably help you better. –  Javier Rivera Mar 4 at 13:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.