Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I reviewed this, and I'm familiar with wlan device disappear (BCM43142) although it seems that the wireless adapter is installed (claimed) correctly, I'm unable to discover all wireless network in range, it only discovers a few.

enclosed a snippet of my machine configuration

$ cat /etc/*release* | grep -i distrib

$ lspci | grep -i bcm
01:00.0 Network controller: Broadcom Corporation BCM43142 802.11b/g/n (rev 01)

$ lshw -c network
       description: Wireless interface
       product: BCM43142 802.11b/g/n
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth3
       version: 01
       serial: c0:18:85:bc:70:ef
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion= (r415941) latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:16 memory:d0500000-d0507fff
       description: Ethernet interface
       product: AR8161 Gigabit Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth2
       version: 10
       serial: 84:8f:69:d4:38:f8
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx duplex=full ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:45 memory:d0400000-d043ffff ioport:2000(size=128)

$ lsmod | grep -i "bcm\|wl"
bcma                   46699  0 
wl                   4207760  0 
lib80211               14381  2 wl,lib80211_crypt_tkip
cfg80211              480503  2 wl,mac80211

$ ifconfig
eth0      Link encap:Ethernet  HWaddr 84:8f:69:d4:38:f8  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::868f:69ff:fed4:38f8/64 Scope:Link
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth1      Link encap:Ethernet  HWaddr c0:18:85:bc:70:ef  
          inet6 addr: fe80::c218:85ff:febc:70ef/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:78 errors:0 dropped:0 overruns:0 frame:0
          TX packets:78 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11043 (11.0 KB)  TX bytes:11043 (11.0 KB)

$ dmesg | grep -i bcm
[    2.135729] usb 2-1.5: Product: BCM43142A0
[   17.274440] eth1: Broadcom BCM4365 802.11 Hybrid Wireless Controller (r415941)

any help will be appreciated!


i also tried the following, but the problem still holds:

$ sudo dpkg-reconfigure bcmwl-kernel-source

and even

$ sudo apt-get autoremove bcmwl-kernel-source
$ sudo apt-get --purge remove bcmwl-kernel-source
$ sudo apt-get install bcmwl-kernel-source

update 2

i even tried to search for any documentation of bcm43142 over linux wireless wiki. surprisingly, there was only one record, which says "unsupported". can it be that the driver, which i am currently using, is detecting only 802.11n, and neither 802.11a/b/g?

update 3

i found a generic driver source from broadcom, and followed the installation manual. but it seems that there is a problem compiling the driver under kernel version 3.10 and above. to check the kernel version execute

$ uname -r

searching around, i found a patch to fix the issue. applying it, let make complete successfully.

$ make
KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: Entering directory `/usr/src/linux-headers-3.11.0-17-generic'
CFG80211 API is prefered for this kernel version
Using CFG80211 API
  LD      /tmp/wlan/built-in.o
  CC [M]  /tmp/wlan/src/shared/linux_osl.o
  CC [M]  /tmp/wlan/src/wl/sys/wl_linux.o
  CC [M]  /tmp/wlan/src/wl/sys/wl_iw.o
  CC [M]  /tmp/wlan/src/wl/sys/wl_cfg80211_hybrid.o
  LD [M]  /tmp/wlan/wl.o
  Building modules, stage 2.
CFG80211 API is prefered for this kernel version
Using CFG80211 API
  MODPOST 1 modules
WARNING: modpost: missing MODULE_LICENSE() in /tmp/wlan/wl.o
see include/linux/module.h for more information
WARNING: modpost: Found 1 section mismatch(es).
To see full details build your kernel with:
  CC      /tmp/wlan/wl.mod.o
  LD [M]  /tmp/wlan/wl.ko
make[1]: Leaving directory `/usr/src/linux-headers-3.11.0-17-generic'

though i am not sure if i should execute make install, since i am not sure of the out come and i really do not want it to break my system.

any advise?

share|improve this question

Problems concerning Broadcom wireless cards not being recognized, panicing the kernel and other compatibility issues, happends on a regular basis. The source may be the Broadcom's package/driver called 'bcmwl-kernel-source', which is automaticaly installed by Ubuntu. Check out what I've written at the link below, and also at the links pointed by it, to see if the case described is the same you're experiencing.

At the end, don't forget to give us a feedback and help the community!


share|improve this answer
firstly, thank you for answering. i am familiar with the packages that you're offering to install, though firmware-b43-installer does not hold the desired driver, and linux-firmware-nonfree is even worse as far as i know, it holds mostly tv cards drivers. and it is not that the wireless is not detected, it does not discover all wireless network in range. – MrRoth Mar 3 '14 at 21:30
and a small recommendation, do not copy-and-paste your answers, just give a reference (link) to it. – MrRoth Mar 3 '14 at 21:35
MrRoth. Sorry if it wasn't your case. The 'linux-firmware-nonfree' package is also for some wireless cards, like mine's. Firmware bugs can cause different and unexpected behavioral anomalies. I didn't copy-and-paste the answer properly, but a small introduction to contextualize the reader ahead the link. – Felipe G. Maia Mar 5 '14 at 1:55

I re-install Ubuntu a lot, and so I know this process all to well.

  1. First you need to get an Ethernet cord.
  2. Then you need another computer and connect them together withe the Ethernet cord.
  3. On the computer that has internet access make sure you turn internet sharing on.

This should give you a wired LAN connection, and then try to install the wireless driver.

share|improve this answer
i already installed my wireless card, it just does not discover all wifi networks in range – MrRoth Mar 8 '14 at 16:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.