Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After spending hours composing a document on AbiWord it suddenly, for no apparent reason, said it needed to close and I lost all my work. Is this a common AbiWord problem, Linux problem or other?

Also any time I am typing, suddenly my last sentence or multiple paragraphs will be randomly slammed into the middle of my work? What's up with that?

Also would you recommend Mint XFCE over Xubuntu? I have a 100GB hard drive and only 1GB RAM which I assume the stock computer uses some of that, but how much I don't know.

share|improve this question
    
What version of Xubuntu are you using, and what version of AbiWord is installed? (I recommend editing your question to add this information.) –  Eliah Kagan Mar 3 at 1:35
    
-1. Way too many questions! Please edit to keep only one question per, well, question. –  landroni Mar 3 at 16:10

2 Answers 2

  1. Keep the zoom level at the 100% default, so AbiWord will have not too much graphics rendering to do.

  2. Your problem with inserting the paragraphs in the middle is being caused by the middle button on the mouse which acts as a copy key to copy from the clipboard. If you are careful to not press the middle button of the mouse when scrolling, you should not have this problem.

  3. You have made a good choice of operating system to match your hardware. Linux Mint is heavier than Xubuntu and may give you worse performance, especially when using the web browser, unless you use the lightweight MATE desktop environment.

To set the autosave time interval in AbiWord:

  1. Select Edit -> Preferences -> Documents tab.

  2. Put a check mark in the checkbox next to Auto Save.

  3. In Interval set the number of minutes after which your document will be automatically saved.

Auto Save is enabled by default in AbiWord, and the default Auto Save Interval is preset to 5 minutes. The .bak~ extension is added to the filename when the document is autosaved so that AbiWord does not overwrite the last version of the file you saved deliberately. This should be left as the default (.bak~) unless you have a really good reason to change it.

If the document has not been created in a folder or saved before, AbiWord will autosave the backup document to your Home directory. After the document has been saved the first time, AbiWord will continue to autosave the .bak~ document to the same directory as the original document. The autosaved backup is a hidden file that can be displayed in the file manager by pressing the keyboard combination Ctrl+H.

share|improve this answer
    
Does Abiword have option to autosave and make backups (like LibreOffice has). If it has, then you can add that to your answer so that even if Abiword crashed OP has recent backup. –  DK Bose Mar 3 at 2:12
    
@DKBose Yes, Abiword has the option to autosave and Auto Save every 5 minutes is enabled by default in AbiWord. The 5 minute Auto Save Interval seems short, but it does help to prevent losing documents when running AbiWord on systems with low hardware configurations. –  karel Mar 3 at 3:16
    
So the good news is that OP did not lose all the work. Maybe OP doesn't know where to look for the backup? Maybe you could add that as well? –  DK Bose Mar 3 at 3:18

I would depreciate Abiword. Try LibreOffice instead. sudo apt-get install libre-office It has equivalents of Microsoft Office's Word, Powerpoint, Excel, Database, and Formula Creation, as well as Drawing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.