Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Couple of issues with the touchpad and trackpoint for my Dell Latitude laptop (Ubuntu 12.04). First, there's no "Touchpad" tab on the Mouse settings in system settings. I'd like to be able to use 2-finger scrolling on the touchpad (and also adjust the sensitivity), and to enable middle-mouse-button scrolling on the trackpoint.

synclient gives an error:

Couldn't find synaptics properties. No synaptics driver loaded?.

The relevent output of xinput is:

    ⎡ Virtual core pointer                      id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
    ⎜   ↳ GlidePoint Virtual Touchpad               id=13   [slave  pointer  (2)]

I found a file in /usr/share/X11/xorg.conf.d/ that has code to enable middle mouse scrolling, but it looks like it's only triggered if TrackPoint|DualPoint Stick is matched in the xinput list? Oddly, the middle-mouse scrolling seems to work only in Chrome's pdf viewer, but no where else.

I tried using gpointer-device-settings but it crashes/segfaults every time I run it. I've tried a couple of things about ALPS drivers, but those seem to come into play when the Glidepoint device shows up in xinput as regular mouse, which I don't think is the case here.

share|improve this question
    
I too am having the issue with no Touchpad tab in the Unity GUI mouse settings. It seems a lot of people have this. Even after installing the proprietary DELL driver, the multi-finger now works, but still no tab. Works with DELL driver: multi-touch multi-touch scrolling mouse jitter stops Doesn't work with DELL driver: coasting (flick scrolling) speed max still requires multiple swipes to get across the screen sensitivity is still pretty poor (pointer doesn't always move) I've been talking to some of the folks at DELL, but don't have a resolution just yet... –  IRTermite Mar 21 at 16:29
    
I am having the same issue on my Dell Latitude 3330 pre-loaded with Ubuntu. The touchpad is not working at all. The Touchpad tab in System Settings is also missing. Please share if anybody finds a solution. Thanks, Suparna –  user226992 Apr 9 at 9:43

1 Answer 1

I have a Dell E7440 with pre-installed Ubuntu 12.04. Here is how I solved issues mentioned by you:

  • I have no "Touchpad" tab on the Mouse settings in system settings but it is not needed since there is a pre-installed tool called "GlidePoint Control Center" or "GlidePoint Touchpad" v.3.6 which allows to setup buttons, motion, tapping, scrolling etc. So all touchpad features can be controlled through it. It can be found here.
  • To enable middle-mouse-button scrolling on the trackpoint I followed this article and the only thing I modified was /usr/share/X11/xorg.conf.d/11-evdev-trackpoint.conf in the MatchProduct section there was no my device which I got through 'xinput' so I added it there. And here is my 11-evdev-trackpoint.conf:

    Section "InputClass"
        Identifier      "trackpoint catchall"
        MatchIsPointer  "true"
        MatchProduct    "TrackPoint|DualPoint Stick|GlidePoint Virtual Touchpad"
        MatchDevicePath "/dev/input/event*"
        Option  "Emulate3Buttons"       "true"
        Option  "EmulateWheel"  "true"
        Option  "EmulateWheelButton"    "2"
        Option  "XAxisMapping"  "6 7"
        Option  "YAxisMapping"  "4 5"
    EndSection
    

As far as I see you have the same device in your 'xinput'. So to enable middle-mouse-button scrolling just modify that file and reboot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.